OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by oso21 - 16.11.2017
Last edited by Yousong Zhou - 30.11.2017

FS#1173 - ustream-ssl Bug ON IPQ806X

LEDE 17.01.4
Kernel 4.9.60
Router: Netgear R7500V2(ARM :IPQ806X)
Packages: Up to Date (2017-11-15)
LuCI works great if Luci-ssl or Luci-openssl is not installed.Once Luci-ssl or Luci-openssl installed with https configuration ,LuCI gets stuck every now and then ,and you`ll have to refresh .When using Firefox ,web crashes and come up with SSL Error: ssl_error_bad_mac_read. Dont know if there is bug in ustream-ssl.


Closed by  Yousong Zhou
30.11.2017 07:06
Reason for closing:  Invalid report
dissent1 commented on 17.11.2017 17:54

What's your wifi throughput?
Seems it's the same error when wifi transmits broken frames that are not corrected. This issue sometimes can be seen by luci (not ssl) broken styles and it surely leads to a permanent low throughput - not more than 40-50 mbits on 5ghz and 20-50 mbits on 2.4ghz

oso21 commented on 18.11.2017 14:05

First of all , low Wi-Fi throuhgput indeed. Secondly, when I switch back to lede17.01 with 4.4 kernel , everything seems fine again . So I assume the problem could be either ustream-ssl or kernel 4.9 .

dissent1 commented on 20.11.2017 10:15

This issue happens on master build with k4.9 and unrelated to ustream-ssl. It's a general problem that has no fix as of yet. Some ppl keep occasionally looking into but no progress ATM.
As an advice if you experience the issue is to stick to 17.01 builds until it is solved.

oso21 commented on 21.11.2017 07:17

Thanks dissent1!Howeber, does it universally hanppen on all platforms or specific ones?

dissent1 commented on 26.11.2017 11:30

For some undiscovered reason it was 1st noticed on netgear r7800 only (other ipq806x doesn't seem to be affected). Considering that you are on r7500v2 it strengthens my concern that it's only netgear ipq806x (uboot?) related.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing