OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Other
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Coleton - 22.11.2017

FS#1186 - In LEDE Reboot 17.01.4 r3560-79f57e422d (AMD64) Intel 3160 AC fails to load module

On LEDE Reboot 17.01.4 r3560-79f57e422d (AMD64) Intel 3160 AC fails to load module after installing the following packages:

kmod-iwlwifi iwlwifi-firmware

(Maybe less relevant information):
The system is a BIOS-mode KVM guest with host-passthrough enabled for the CPU.
The CPU for the host system is an Intel E3-1260L which supports Intel VT-d for PCI-e passthrough so the Intel 3160 AC is accessible via LEDE.
This was not an issue in OpenWRT’s snapshot trunk branch running kernel 4.4.14, however I upgraded to LEDE as it supports more for what I need.

lscpu output from host:

# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                8
On-line CPU(s) list:   0-7
Thread(s) per core:    2
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 42
Model name:            Intel(R) Xeon(R) CPU E31260L @ 2.40GHz
Stepping:              7
CPU MHz:               3157.763
CPU max MHz:           3300.0000
CPU min MHz:           1600.0000
BogoMIPS:              4789.02
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              8192K
NUMA node0 CPU(s):     0-7
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts

Versions of

kmod-iwlwifi iwlwifi-firmware

affected:

opkg info kmod-iwlwifi iwlwifi-firmware
Package: kmod-iwlwifi
Version: 4.4.92+2017-01-31-3
Depends: kernel (= 4.4.92-1-6cc8de69a849e6105fc9972ed7f32449), kmod-mac80211, iwlwifi-firmware
Status: install user installed
Section: kernel
Architecture: x86_64
Size: 254871
Filename: kmod-iwlwifi_4.4.92+2017-01-31-3_x86_64.ipk
Description: iwlwifi kernel module for
 Intel Wireless WiFi Link 6250AGN Adapter
 Intel 6000 Series Wi-Fi Adapters (6200AGN and 6300AGN)
 Intel WiFi Link 1000BGN
 Intel Wireless WiFi 5150AGN
 Intel Wireless WiFi 5100AGN, 5300AGN, and 5350AGN
 Intel 6005 Series Wi-Fi Adapters
 Intel 6030 Series Wi-Fi Adapters
 Intel Wireless WiFi Link 6150BGN 2 Adapter
 Intel 100 Series Wi-Fi Adapters (100BGN and 130BGN)
 Intel 2000 Series Wi-Fi Adapters
 Intel 7260 Wi-Fi Adapter
 Intel 3160 Wi-Fi Adapter
 Intel 7265 Wi-Fi Adapter
 Intel 8260 Wi-Fi Adapter
 Intel 3165 Wi-Fi Adapter
Installed-Time: 1511359008

How I have been able to reproduce the issue:

  • Remove
    kmod-iwlwifi iwlwifi-firmware

    via:

    opkg remove kmod-iwlwifi iwlwifi-firmware && reboot;exit
  • Reinstall
    kmod-iwlwifi iwlwifi-firmware

    via:

    opkg remove kmod-iwlwifi iwlwifi-firmware && reboot;exit

    - In this step wlan0 appears, however it loads with the following errors:

# dmesg
...
[  118.600835] random: nonblocking pool is initialized
[  124.489097] Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f
[  124.491388] Backport generated by backports.git backports-20160324-13-g24da7d3c
[  124.495502] Intel(R) Wireless WiFi driver for Linux
[  124.496759] Copyright(c) 2003- 2015 Intel Corporation
[  124.520049] iwlwifi 0000:00:09.0: loaded firmware version 17.352738.0 op_mode iwlmvm
**[  124.524141] iwlwifi 0000:00:09.0: failed to load module iwlmvm (error -2), is dynamic loading enabled?**
[  124.529146] iwlwifi 0000:00:09.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[  124.534526] iwlwifi 0000:00:09.0: L1 Enabled - LTR Disabled
[  124.536264] iwlwifi 0000:00:09.0: L1 Enabled - LTR Disabled
[  124.654517] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
  • A reboot will result in wlan0 going away and the following errors:
# dmesg
[    4.112006] NET: Registered protocol family 24
**[    4.113940] iwlwifi 0000:00:09.0: failed to load module iwlmvm (error -2), is dynamic loading enabled?**
[    4.117011] iwlwifi 0000:00:09.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[    4.121443] iwlwifi 0000:00:09.0: L1 Enabled - LTR Disabled
[    4.123209] iwlwifi 0000:00:09.0: L1 Enabled - LTR Disabled
[    4.240761] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing