OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by build000 - 14.01.2018
Last edited by Ted Hess - 11.02.2018

FS#1277 - WNDR4700 (apm821xx) - usb3 not properly configure/install/working ports (all)

Openwrt/Lede version - r5812-d667909

logread:

(...)
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led SATA
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN (green)
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN (yellow)
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led USB3
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: /etc/rc.common: eval: line 1: can't create /sys/class/leds/wndr4700:blue:usb/ports/usb3-port1: Permission denied
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: /etc/rc.common: eval: line 1: can't create /sys/class/leds/wndr4700:blue:usb/ports/usb3-port2: Permission denied
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led WLAN2G
Sun Jan 14 20:27:45 2018 daemon.notice procd: /etc/rc.d/S96led: setting up led WLAN5G
(...)

update kernel to 4.14.* version = this error
Attached config (old for use FastPath /disabled - not compile/ = not important modification for to usb3 problem)

   .config (220.7 KiB)
Closed by  Ted Hess
11.02.2018 14:05
Reason for closing:  Not a bug
build000 commented on 14.01.2018 23:07

Ehh - I'am "imbecile" (hehe) - Sorry - not properly LED-USB3 working (not working)...

cat /etc/config/system:

(...)
config led 'led_usb3'
	option name 'USB3'
	option sysfs 'wndr4700:blue:usb'
	option trigger 'usbport'
	list port 'usb2-port1'
	list port 'usb2-port2'
	list port 'usb3-port1'
	list port 'usb3-port2'
(...)
build000 commented on 14.01.2018 23:21

ehh - I am...a very sleepy man
fixing problem using Luci and usb3 (and USB3-LED) working fine:

cat /etc/config/system:

(...)
config led 'led_usb3'
	option name 'USB3'
	option sysfs 'wndr4700:blue:usb'
	option trigger 'usbport'
	option default '0'
	list port 'usb1-port1'
	list port 'usb1-port2'
	list port 'usb2-port1'
	list port 'usb2-port2'
(...)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing