LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: LEDE Project
Opened by Antonio - 04.05.2017

FS#759 - EA4500 with mwk8k driver: Wireless instability and WPA-EAP does not work

Device: Linksys EA4500 (mwl8k driver)
LEDE: 17.01.1

Hi all
I would like to recall to attention an issue that various user are
observing running mwl8k driver together with android and iOS clients
Relevant information can be found here:

https://dev.openwrt.org/ticket/21284 http://www.spinics.net/lists/linux-wireless/msg151171.html

I can add that the problem seems to get worst depending on the
bandwidth usage (higher is worst).
And I can confirm that apparently only android clients are affected,
in the sense that here I have also iPhones and some IP WebCam that
work rock stable with the same router.
Also both 5Ghz and 2.5Ghz radio are affected
Userland seems to have no influence, I have tried wpad and hostapd.
Actually I was trying to workaround the below problem using WPA2-EAP.
But the PEAP-mschapv2 doesn’t work with mwl8k driver on 5Ghz radio
My setup include two different Cisco/Linksys EA4500 running LEDE
17.01.1 and one TPLink WDR3600 with ath9x radios
The EA4500 chipset is Marvell 88W8366 v48.
Well with both 5Ghz radio of my two EA4500 the PEAP MSCHAPV2
authentication fails at the certificates exchange
This is the log I see in freeradius 2

Wed May 3 21:17:26 2017 : Debug: Going to the next request
Wed May 3 21:17:26 2017 : Debug: Waking up in 4.9 seconds.
Wed May 3 21:17:31 2017 : Info: Cleaning up request 34 ID 41 with timestamp +574
Wed May 3 21:17:31 2017 : Info: Cleaning up request 35 ID 42 with timestamp +574
Wed May 3 21:17:31 2017 : Info: Cleaning up request 36 ID 43 with timestamp +574
Wed May 3 21:17:31 2017 : Debug: WARNING:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Wed May 3 21:17:31 2017 : Debug: WARNING: !! EAP session for state
0xd1f19d03d34c849e did not finish!
Wed May 3 21:17:31 2017 : Debug: WARNING: !! Please read
http://wiki.freeradius.org/guide/Certificate_Compatibility Wed May 3 21:17:31 2017 : Debug: WARNING:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Wed May 3 21:17:31 2017 : Info: Ready to process requests.

On hostapd size the logs say that the radius response is received but
the next stage never arrives.
Using the same freeradius 2 I can get PEAP working with the 2.4Ghz
radio with no issue and most important with both 2.4Ghz and 5Ghz radio
on wdr3600, that run the same LEDE release (same kernel) and the same
userland app, so it seems that the problem is really in the
interaction between the mwl8k driver, 5Ghz radio and hostapd and
freeradius.
The problem is shared by two android device (one 7.0.1 and one 6.1)
and and iPhone 7.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing