LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Medium
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: LEDE Project
Opened by Ken - 06.05.2017
Last edited by Mathias Kresin - 22.07.2017

FS#763 - No IPv4 DHCP address are issued on LAN

This is a strange one : I installed “LEDE 17.01.1” on a GL-AR150 , and when I plugged into the LAN port, it didn’t give me an IPv4 address. I got in on an IPv6 address and found that /var/etc/dnsmasq.conf.cfg02411c didn’t have a “dhcp-range” entry.

Strange. I did network.lan.ipaddr=192.168.2.1 , and rebooted and it issues IPv4 addresses.

“LEDE 17.01.0” worked fine on this GL-AR150

More strange is that I have another GL-AR150, and it works fine on that. The only difference is that the broken one has a POE module (but that’s on the WAN port).

Supply the following if possible:

- Device problem occurs on

GL-AR150

- Software versions of LEDE release, packages, etc.

“LEDE 17.01.1”

- Steps to reproduce

All I did was install “LEDE 17.01.1” on a GL-AR150.

Here’s a little table of what works and what doesn’t :

"LEDE 17.01.0" on dev0 => works OK
"LEDE 17.01.0" on dev1 => works OK
"LEDE 17.01.1" on dev1 => works OK

"LEDE 17.01.1" on dev0 => no "dhcp-range" in /var/etc/dnsmasq.conf.cfg02411c
"LEDE 17.01.1" on dev0 , network.lan.ipaddr=192.168.2.1 => works OK


Closed by  Mathias Kresin
22.07.2017 10:46
Reason for closing:  Fixed
Ken commented on 06.05.2017 06:32

Update : I got the other GL-AR150 ("dev1" in the table above) to show the symptom.

Here's a clue : if I do "/etc/init.d/dnsmasq restart", then it works OK.

Ken commented on 09.05.2017 06:13

Update : network.lan.ipaddr=192.168.2.1 doesn't always fix it .

"/etc/init.d/dnsmasq restart" always fixes it.

I suspect a race condition. Dunno why I've only seen it on the GL-AR150.

Paul Oranje commented on 10.05.2017 11:06

When another DHCP service is running on the same LAN, then /etc/init.d/dnsmasq will not start DHCP on that LAN. So, are you sure no other device is serving DHCP on your LAN ?

Bluse-Blue commented on 10.05.2017 15:37

HI,

I discovered a similar issue where the dhcp range is empty in the dnsmaqs config I opened a tickert for this [1]
My observation is that in such cases where no ethernet cable is plugged into the router while it boots up, then there is not carrier detected and hence no dhcp range set up - no dhcp working. Once the carrier is detected it should trigger a hotplug event the start the dhcp with proper range on that interface, but this is not working currently.

Greetings Thomas

[1] https://bugs.lede-project.org/index.php?do=details&task_id=765&string=cpe510&search_name=&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

Ken commented on 07.06.2017 17:20

I just saw this on a "NETGEAR WNDR3700v4" as well : no IPv4 address issued.

Strange. Perhaps it's some kind of race, because it's intermittent.

I got in on the "link local" IPv6 address, and found no "dhcp-range" in /var/etc/dnsmasq.conf.cfg02411c

I changed a few things (hostname, turned on radios, etc), and rebooted and now it's issuing IPv4 addresses.

BTW, to calculate the "link local" IPv6 address, use "RFC4291 Appendix A".

Baptiste Jonglez commented on 12.07.2017 09:54

Can you try with lede 17.01.2? dnsmasq got a few updates since 17.01.1.

Ken commented on 22.07.2017 06:12

I tried LEDE Reboot (17.01.2, r3435-65eec8bd5f) on a "NETGEAR WNDR3700v4" and it issued IPv4 addresses OK.

I also tried 2 gl-ar150 routers, and they issued IPv4 addresses, so maybe it's fixed...

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing