LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: LEDE Project
Opened by Nicolò - 14.06.2017
Last edited by Yousong Zhou - 04.07.2017

FS#846 - MT7628 : MMC driver not reading the mmc partition table

Hi
I have a WRTNode 2p Based on the mt7628an.

By inserting a sd on the board and installing the appropriate kernel module, the chip recognizes the SD card, but the partitions are not. (Obviously mmcblk0 is not mountable)

At this point thinking that my sd was not formatted I formatted it from LEDE, I have created a partition and formatted it.
I removed and re-inserted the sd, at this point the partition was recognized and I could mount it and copy data on it.

I than removed the SD and connected it to a PC, the pc does not see the partitions I just created.
I tried to put the sd back on the device and LEDE recognizes it and also finds the partitions.

Thinking that it was my PC I changed with another one but also in that case the card remains inaccessible.

I then partitioned again and formatted the card from a PC. LEDE does not see the partition.
I have no idea where the problem might be.

I also tested this with the stable release of LEDE and the problem still occurs.

dmesg

Regards,
hitech95


Closed by  Yousong Zhou
04.07.2017 03:24
Reason for closing:  Not a bug
Project Manager
Alexander Couzens commented on 19.06.2017 18:15

try to read certain amount of megabytes

dd if=/dev/mmcblk0 of=/tmp/foo bs=1M count=4
sha256sum /tmp/foo

do the same using a desktop/laptop to verify the result. You should take care the filesystem is *NOT* automounted by the desktop as it might falsefy the result, because mounting a filesystem usually modify timestamps.

Nicolò commented on 01.07.2017 18:50

Looks like it is an error on the hardware. The board have swapped d3 and d2.

After swapping those pins all works fine.
Bootlog Hardware Mod

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing