LEDE Project

Welcome to the LEDE Project bug reporting and issue tracking system

Problems to be reported here are for the LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the LEDE Project website. Problems related to LuCI or OpenWrt/LEDE packages need to be reported in their repositories:

Notifications of all submissions and task changes are sent to lede-bugs@infradead.org.

OpenedIDCategoryTask TypePrioritySeveritySummaryReported InStatus  desc
06.05.2017764KernelBug ReportVery LowMediumMT7621: Any traffic shaping results in crashes/stack tr...AllRequires testing Task Description

There has been a large number of reports of bugs with MT7621 devices in combination with SQM. Debugging is difficult, because it often results in a hardcrash which leaves no log files. I believe I have some interesting details that might make it easier to debug.

Device: DIR-860L rev B1, but according to reports all MT7621 devices are affected.
LEDE Version: LEDE Reboot SNAPSHOT r4094-961c0ea
Steps to reproduce: Run a dslreports.com speedtest with a large number of upload and download streams (32/32) with either SQM or QOS enabled on your WAN interface.

Observations:

  • It happens both with SQM-scripts _and_ QOS. So I don’t believe it is an issue with the SQM package specifically. These two packages have in common that they both shape traffic.
  • It seems to be load dependent. 100/100 and 200/200 mbit egress/ingress limits crash less often than 300/300 or higher limits
  • It happens with all qdiscs: Cake + piece of cake, fq_codel + simple, fq_codel + simplest

Crash log:

There is usually no crash log because the router hardlocks and then reboots. But I got very lucky once and managed to get a log of the event:

[  710.140000] INFO: rcu_sched detected stalls on CPUs/tasks:
[  710.150000] 	1-...: (257 GPs behind) idle=dfc/0/0 softirq=48167/48179 fqs=1 
[  710.160000] 	(detected by 2, t=6004 jiffies, g=13114, c=13113, q=1063)
[  710.170000] Task dump for CPU 1:
[  710.180000] swapper/1       R running      0     0      1 0x00100000
[  710.190000] Stack : 00000000 5b6c286a 000000a3 ffffffff 00000090 773742c0 804df2a4 80490000
[  710.190000] 	  8048c75c 00000001 00000001 8048c540 8048c724 80490000 00000000 800135e4
[  710.190000] 	  00000000 00000001 87c70000 87c71ec0 80490000 8005ec74 1100fc03 00000001
[  710.190000] 	  00000000 80490000 804df2a4 8005ec6c 80490000 8001b1a8 1100fc03 00000000
[  710.190000] 	  00000004 8048c4a0 000000a0 8001b1b0 8c94e220 00008018 dc124877 a0020044
[  710.190000] 	  ...
[  710.260000] Call Trace:
[  710.270000] [<8000be98>] __schedule+0x574/0x758
[  710.280000] [<800135e4>] r4k_wait_irqoff+0x0/0x20
[  710.290000] 
[  710.290000] rcu_sched kthread starved for 6016 jiffies! g13114 c13113 f0x0 s3 ->state=0x1
[  782.470000] INFO: rcu_sched detected stalls on CPUs/tasks:
[  782.470000] 	1-...: (0 ticks this GP) idle=12c/0/0 softirq=48179/48179 fqs=0 
[  782.470000] 	(detected by 0, t=6002 jiffies, g=13324, c=13323, q=1260)
[  782.470000] Task dump for CPU 1:
[  782.470000] swapper/1       R running      0     0      1 0x00100000
[  782.470000] Stack : 00000000 00000001 0000000a 00000000 00000000 00000001 804df2a4 80490000
[  782.470000] 	  8048c75c 00000001 00000001 8048c540 8048c724 80490000 00000000 800135e4
[  782.470000] 	  00000000 00000001 87c70000 87c71ec0 80490000 8005ec74 1100fc03 00000001
[  782.470000] 	  00000000 80490000 804df2a4 8005ec6c 80490000 8001b1a8 1100fc03 00000000
[  782.470000] 	  00000004 8048c4a0 000000a0 8001b1b0 8c94e220 00008018 dc124877 a0020044
[  782.470000] 	  ...
[  782.470000] Call Trace:
[  782.470000] [<8000be98>] __schedule+0x574/0x758
[  782.470000] [<800135e4>] r4k_wait_irqoff+0x0/0x20
[  782.470000] 
[  782.470000] rcu_sched kthread starved for 6002 jiffies! g13324 c13323 f0x0 s3 ->state=0x1
[  860.040000] INFO: rcu_sched detected stalls on CPUs/tasks:
[  860.050000] 	1-...: (0 ticks this GP) idle=5a8/0/0 softirq=48179/48179 fqs=0 
[  860.060000] 	(detected by 3, t=6004 jiffies, g=13501, c=13500, q=2389)
[  860.070000] Task dump for CPU 1:
[  860.080000] swapper/1       R running      0     0      1 0x00100000
[  860.090000] Stack : 00000000 00002cd1 00000000 777882c0 00000000 00000000 804df2a4 80490000
[  860.090000] 	  8048c75c 00000001 00000001 8048c540 8048c724 80490000 00000000 800135e4
[  860.090000] 	  00000000 00000001 87c70000 87c71ec0 80490000 8005ec74 1100fc03 00000001
[  860.090000] 	  00000000 80490000 804df2a4 8005ec6c 80490000 8001b1a8 1100fc03 00000000
[  860.090000] 	  00000004 8048c4a0 000000a0 8001b1b0 8c94e220 00008018 dc124877 a0020044
[  860.090000] 	  ...
[  860.160000] Call Trace:
[  860.170000] [<8000be98>] __schedule+0x574/0x758
[  860.180000] [<800135e4>] r4k_wait_irqoff+0x0/0x20
[  860.190000] 
[  860.190000] rcu_sched kthread starved for 6017 jiffies! g13501 c13500 f0x0 s3 ->state=0x1

I hope it contains useful information for tracking down this bug. If there is anything else I can supply or test in order to help the debugging process, please let me know.

28.06.2017873Base systemBug ReportVery LowMediumproblems of mt7628 wifi driver on miwifi nanoAllRequires testing Task Description

I started using lede on my miwifi nano since the release of version 17.01.1. All function works well except its wireless function.

What makes it a problem is its stability. After a random period of time(ranging from a quarter of an hour to half of a day), it suddenly disconnected. If you try to reconnect, my device shows something like “setting the network address”(varing from devices to devices). After reboot, I found something like “deauthenticated due to inactivity (timer DEAUTH/REMOVE)”. Unfortunately, I haven’t found a way to reproduce the problem till now.

I thought there might be bugs on its wireless driver because on another firmware(http://downloads.pandorabox.com.cn/pandorabox/Xiaomi-Mini-R1CL/firmware/PandoraBox-ralink-mt7628-xiaomi-r1cl-squashfs-sysupgrade-r1752-20151201.bin) which is a variant of Openwrt, it works well.

There are many other problems like the inability to set channel to auto and the txpower option is of no use. But for my daily use, they may not so important compared to the connectivity problem.

Sorry for my bad English and thank you for fixing it.

19.05.2017796KernelBug ReportVery LowLowMulti-SSID does not work on MT7603 (ZBT-3526) at 2.4 G...AllRequires testing Task Description

Device: ZBT-3526
Packages used for wireless:
kmod-cfg80211 4.4.61+2017-01-31-1
kmod-mac80211 4.4.61+2017-01-31-1
kmod-mt76 4.4.61+2017-03-17-712..f-2
kmod-mt76-core 4.4.61+2017-03-17-712..f-2
kmod-mt7603 4.4.61+2017-03-17-712..f-2
kmod-mt76x2 4.4.61+2017-03-17-712..f-2

Throughput is very poor if I perform an iPerf test on the second 2.4 GHz SSID.

Server (WG3526) iperf -s


Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)


[ 4] local 10.3.231.1 port 5001 connected with 10.3.231.108 port 60952
[ ID] Interval Transfer Bandwidth
[ 4] 0.0-20.9 sec 256 KBytes 100 Kbits/sec

Client (laptop) iperf -c 10.3.231.1 -i 2 -w 128KB


Client connecting to 10.3.231.1, TCP port 5001
TCP window size: 256 KByte (WARNING: requested 128 KByte)


[ 3] local 10.3.231.108 port 60952 connected with 10.3.231.1 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0- 2.0 sec 128 KBytes 524 Kbits/sec
[ 3] 2.0- 4.0 sec 0.00 Bytes 0.00 bits/sec
[ 3] 4.0- 6.0 sec 0.00 Bytes 0.00 bits/sec
[ 3] 6.0- 8.0 sec 0.00 Bytes 0.00 bits/sec
[ 3] 8.0-10.0 sec 0.00 Bytes 0.00 bits/sec
[ 3] 10.0-12.0 sec 0.00 Bytes 0.00 bits/sec
[ 3] 0.0-20.9 sec 256 KBytes 101 Kbits/sec

My /etc/config/wireless file is

config wifi-device ‘radio0’

option type 'mac80211'
option hwmode '11g'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'HT20'
option disabled '0'
option country 'IT'
option channel '13'
option txpower '20'

config wifi-device ‘radio1’

      option type 'mac80211'
      option channel '36'
      option hwmode '11a'
      option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
      option htmode 'VHT80'
      option disabled '0'

config wifi-iface

      option device 'radio0'
      option mode 'ap'
      option ssid 'Private-bgn'
      option network 'lan'
      option encryption 'psk2'
      option key 'testtest'

config wifi-iface

      option device 'radio1'
      option mode 'ap'
      option ssid 'Private'
      option network 'lan'
      option encryption 'psk2'
      option key 'testtest'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option isolate '1'
option ssid 'Public-bgn'

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option encryption 'none'
option isolate '1'
option ssid 'Public'
16.07.2017909Base systemBug ReportVery LowLowrunas wrapper executes programs using wrong interpreterTrunkRequires testing Task Description

I happen to run a system having no easily accessible binary interpreter (that is, there is no `/lib64`).

Some time ago a wrapper for binaries was introduced. The issue with this wrapper is that instead of using bundled `ld-linux-x86-64.so.2`, it executes the program by calling `execve`, which will try to use the system interpreter (and fail, in my case). In other words, all the bundled dynamic loader business is now out of work; the same result could be achieved by executing the binary directly.

This works:

[staging_dir/host]$ ./lib/ld-linux-x86-64.so.2 --library-path ./lib/ ./bin/.uuidgen.bin
fb85483b-e891-4dbd-badb-43361fc954f3

This does not:

[staging_dir/host]$ ./lib/ld-linux-x86-64.so.2 --library-path ./lib/ ./lib/runas ./bin/.uuidgen.bin uuidgen
[staging_dir/host]$ echo $?
255
[staging_dir/host]$ strace ./lib/ld-linux-x86-64.so.2 --library-path ./lib/ ./lib/runas ./bin/.uuidgen.bin uuidgen
execve("./lib/ld-linux-x86-64.so.2", ["./lib/ld-linux-x86-64.so.2", "--library-path", "./lib/", "./lib/runas", "./bin/.uuidgen.bin", "uuidgen"], 0x7ffe055921b8 /* 69 vars */) = 0
brk(NULL)                               = 0x55c6f060e000
open("./lib/runas", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\2\0>\0\1\0\0\0\240\4@\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=7048, ...}) = 0
getcwd("/home/kirelagin/openwrt/lede-imagebuilder-17.01.2-ar71xx-generic.Linux-x86_64/staging_dir/host", 128) = 95
mmap(0x400000, 4096, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0) = 0x400000
mmap(0x600000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0) = 0x600000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f157c858000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("./lib/tls/x86_64/libc.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("./lib/tls/libc.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("./lib/x86_64/libc.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("./lib/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\3\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0P\34\2\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1738176, ...}) = 0
getcwd("/home/kirelagin/openwrt/lede-imagebuilder-17.01.2-ar71xx-generic.Linux-x86_64/staging_dir/host", 128) = 95
mmap(NULL, 3844640, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f157c4ad000
mprotect(0x7f157c64e000, 2097152, PROT_NONE) = 0
mmap(0x7f157c84e000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1a1000) = 0x7f157c84e000
mmap(0x7f157c854000, 14880, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f157c854000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f157c4ac000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f157c4ab000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f157c4aa000
arch_prctl(ARCH_SET_FS, 0x7f157c4ab700) = 0
mprotect(0x7f157c84e000, 16384, PROT_READ) = 0
mprotect(0x55c6f00e8000, 4096, PROT_READ) = 0
execve("./bin/.uuidgen.bin", ["uuidgen"], 0x7ffd9e14e360 /* 69 vars */) = -1 ENOENT (No such file or directory)
exit_group(-1)                          = ?
+++ exited with 255 +++
23.05.2017800KernelBug ReportVery LowCriticalath9k sta and ap mode change. system hangTrunkWaiting on reporter Task Description

mips device with ar9580 wireless card sta and ap mode change by use test.sh
test.sh
while [ 1 ]
do
mv /etc/config/wireless /etc/config/wirelessbak
mv /etc/config/wireless1 /etc/config/wireless
mv /etc/config/wirelessbak /etc/config/wireless1
/etc/init.d/network restart
sleep 50
done

I found the system will hang , It like a deadlock but I can’t verify

Use the same shell I change the ath9k code

just delete the full sleep timer

modify ath9k_ps_wakeup ath9k_ps_restore
delete mod_timer(&sc→sc_pm_lock,flags);
detete del_timer_sync(&sc→sc_pm_lock);
The system run ok

 


21.11.2016295KernelBug ReportVery LowHighath10k_pci 0001:01:00.0: SWBA overrun on vdevTrunkWaiting on reporter Task Description

Supply the following if possible:

- TP-LINK c2600 v1.1
- LEDE Reboot r2244
- after some hours, the network device produce the below stacktrace.

[61789.980553] ————[ cut here ]———— [61789.980600] WARNING: CPU: 0 PID: 3 at net/core/dev.c:4837 net_rx_action+0×154/0x2e4()
[61789.984240] Modules linked in: pppoe ppp_async iptable_nat pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY ts_kmp ts_fsm ts_bm slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_netlink nf_conntrack iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt br_netfilter em_cmp sch_teql em_nbyte sch_htb sch_pie sch_gred sch_dsmark cls_basic act_ipt sch_prio em_text
[61790.061568] sch_codel sch_tbf sch_sfq em_meta act_police sch_fq sch_red act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ath10k_pci ath10k_core ath mac80211 cfg80211 compat ledtrig_usbport xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ifb ip6_tunnel tunnel6 tun snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd input_core soundcore
[61790.130320] usb_storage uhci_hcd f2fs ext4 jbd2 mbcache crc32c_generic crypto_hash leds_gpio xhci_plat_hcd xhci_pci xhci_hcd dwc3 dwc3_qcom dwc3_of_simple ohci_platform ohci_hcd phy_qcom_dwc3 ahci ehci_platform ehci_hcd sd_mod ahci_platform libahci_platform libahci libata scsi_mod gpio_button_hotplug usbcore nls_base usb_common
[61790.158798] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 4.4.30 #0
[61790.159062] Hardware name: Qualcomm (Flattened Device Tree)
[61790.165160] [<c02207f4>] (unwind_backtrace) from [<c021d2e4>] (show_stack+0×14/0×20)
[61790.170534] [<c021d2e4>] (show_stack) from [<c03b82a4>] (dump_stack+0x8c/0xa0)
[61790.178521] [<c03b82a4>] (dump_stack) from [<c0228aec>] (warn_slowpath_common+0xa4/0xd0)
[61790.185550] [<c0228aec>] (warn_slowpath_common) from [<c0228bcc>] (warn_slowpath_null+0x1c/0×24)
[61790.193798] [<c0228bcc>] (warn_slowpath_null) from [<c050bcd0>] (net_rx_action+0×154/0x2e4)
[61790.202568] [<c050bcd0>] (net_rx_action) from [<c022bc90>] (do_softirq+0xdc/0×230)
[61790.210636] [<c022bc90>] (
do_softirq) from [<c022be18>] (run_ksoftirqd+0×34/0×64)
[61790.218626] [<c022be18>] (run_ksoftirqd) from [<c0246784>] (smpboot_thread_fn+0×190/0x1b8)
[61790.226006] [<c0246784>] (smpboot_thread_fn) from [<c02438e4>] (kthread+0xf8/0×100)
[61790.234335] [<c02438e4>] (kthread) from [<c0209cb8>] (ret_from_fork+0×14/0x3c)
[61790.241951] —[ end trace bbf62e8dea16c714 ]— [61790.250226] ath10k_pci 0001:01:00.0: SWBA overrun on vdev 1, skipped old beacon

28.02.2017569Base systemBug ReportVery LowHighUnable to conenct with wpa2-eaplede-17.01Waiting on reporter Task Description

Device: TP-Link Archer C7 V2
LEDE: 17.01.0, r3205-59508e3

Sometimes it is impossible to connect to an AP. It just looks like that he pairwise key handshake fails. This is what i see in the log:

Feb 28 20:13:41 10.0.0.3 hostapd: wlan1: STA 00:13:ef:60:0a:3a IEEE 802.11: authenticated
Feb 28 20:13:41 10.0.0.3 hostapd: wlan1: STA 00:13:ef:60:0a:3a IEEE 802.11: associated (aid 1)
Feb 28 20:13:41 10.0.0.3 hostapd: wlan1: CTRL-EVENT-EAP-STARTED 00:13:ef:60:0a:3a
Feb 28 20:13:41 10.0.0.3 hostapd: wlan1: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=1

My config for wpa2-eap is pretty simple:

config wifi-iface ‘default_radio1’

      option device 'radio1'
      option mode 'ap'
      option ssid 'SSID'
      option encryption 'wpa2'
      option auth_server '10.0.0.1'
      option auth_port '1812'
      option auth_secret 'foobar'
      option nasid 'ap02g'
      option network 'lan'
      option wpa_group_rekey '2000'
10.04.2017697Base systemBug ReportVery LowHighLEDE tl-wdr3320-v2 No 2.4GHzlede-17.01Waiting on reporter Task Description

ar9344+ar9287

this:
https://downloads.lede-project.org/releases/17.01.0/targets/ar71xx/generic/lede-17.01.0-r3205-59508e3-ar71xx-generic-tl-wdr3320-v2-squashfs-sysupgrade.bin
No 2.4GHz

16.08.2017963KernelBug ReportVery LowHighchips is qca9531, pc ping device ip fail or timeout wit...lede-17.01Waiting on reporter Task Description

this problem is always occurs on.

Steps:

  My device is router, chip is QCA9531.
  PC ip is 192.168.1.100, router ip is 192.168.1.1.
  PC execute command "ping 192.168.1.1 -l 65500 -t" fail or timeout.


24.10.20171111Base systemBug ReportVery LowHighI have fresh install on WR740N and I discovered ip6tabl...lede-17.01Waiting on reporter Task Description

Supply the following if possible:
- Device problem occurs on — is TP-link WR740N
- Software versions of LEDE release, packages, etc. — base image no additional packages
- Steps to reproduce:

 

I have fresh install on WR740N and I discovered ip6tables setup is empty (”ip6tables –list -nv” shows everything is ACCEPTed), while ink-local fe80::... address is active on wan interface and web-interface listens on it since

$ netstat -apn
...
tcp 0 0 :::80 :::* LISTEN 754/uhttpd
...

02.11.2016263KernelBug ReportVery LowMediumWRT3200ACM WAN connection failure in under 24 hoursTrunkWaiting on reporter Task Description

Symptom

WAN connectivity is lost until the device is rebooted; failure aligns with stack trace (attached). I’ve observed three failures of this same type, and all have occurred at around 18 hours of device up time. Work-around (yet to be tested) is to schedule a periodic device reboot every 12 hours.

Device problem occurs on

  • Linksys WRT3200ACM (version 1)
  • LEDE configuration is near-stock, with the only modifications being PPPoE configuration and WiFi setup/enable. Issue does not appear to be similar to FS#227 (PPPoE).

Software versions of LEDE release, packages, etc.

Release:

  [0.000000] Linux version 4.4.28 (buildbot@builds) (gcc version 5.4.0 (LEDE GCC 5.4.0 r2062) ) #0 SMP Mon Oct 31 16:13:37 2016
  [0.000000] CPU: ARMv7 Processor [414fc091] revision 1 (ARMv7), cr=10c5387d
  [0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
  [0.000000] Machine model: Linksys WRT3200ACM

Packages:

  Default packages + luci-ssl

Possibly helpful info (80211 related output in log):

  <<Marvell 802.11ac Wireless Network Driver version 10.3.2.0-20161011>>
  pci 0000:00:01.0: enabling device (0140 -> 0142)
  ieee80211 phy0: priv->iobase0 = e0e00000
  ieee80211 phy0: priv->iobase1 = e1080000
  ieee80211 phy0: priv->pcmd_buf = de248000  priv->pphys_cmd_buf = 1e248000
  ieee80211 phy0: fw download start
  ieee80211 phy0: FwSize = 207660 downloaded Size = 207660 curr_iteration 65522
  ieee80211 phy0: fw download complete
  ieee80211 phy0: pcmd = de248000
  ieee80211 phy0: firmware version: 0x7080004
  ieee80211 phy0: firmware region code: 10
  ieee80211 phy0: 2G disabled, 5G enabled
  ieee80211 phy0: 4 TX antennas, 4 RX antennas
  pci 0000:00:02.0: enabling device (0140 -> 0142)
  ieee80211 phy1: priv->iobase0 = e1200000
  ieee80211 phy1: priv->iobase1 = e1480000
  ieee80211 phy1: priv->pcmd_buf = dda20000  priv->pphys_cmd_buf = 1da20000
  ieee80211 phy1: fw download start
  ieee80211 phy1: FwSize = 207660 downloaded Size = 207660 curr_iteration 65527
  ieee80211 phy1: fw download complete
  ieee80211 phy1: pcmd = dda20000
  ieee80211 phy1: firmware version: 0x7080004
  ieee80211 phy1: firmware region code: 10
  ieee80211 phy1: 2G enabled, 5G disabled
  ieee80211 phy1: 4 TX antennas, 4 RX antennas

Steps to reproduce

Device was idle before the stack trace, but logs show some DHCP-related activity within 1 minute prior to the fault.

Stack Trace

Wed Nov  2 17:10:41 2016 kern.err kernel: [74541.045379] ieee80211 phy1: create ba result error 1
Wed Nov  2 17:10:41 2016 kern.err kernel: [74541.059396] ieee80211 phy1: ampdu operation error code: -22
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.085673] ------------[ cut here ]------------
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.090364] WARNING: CPU: 0 PID: 5305 at compat-wireless-2016-10-08/net/mac80211/agg-tx.c:398 ___ieee80211_stop_tx_ba_session+0x1e8/0x1f8 [mac80211]()
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.103914] Modules linked in: pppoe ppp_async iptable_nat pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_fWed Nov  2 17:10:42 2016 kern.warn kernel: [74542.162765] CPU: 0 PID: 5305 Comm: kworker/u4:2 Not tainted 4.4.28 #0
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.169230] Hardware name: Marvell Armada 380/385 (Device Tree)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.175192] Workqueue: phy1 ieee80211_iface_work [mac80211]
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.180804] [<c0027d80>] (unwind_backtrace) from [<c0024500>] (show_stack+0x10/0x14)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.188584] [<c0024500>] (show_stack) from [<c021779c>] (dump_stack+0x8c/0xa0)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.195838] [<c021779c>] (dump_stack) from [<c0034e5c>] (warn_slowpath_common+0x94/0xb0)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.203962] [<c0034e5c>] (warn_slowpath_common) from [<c0034f14>] (warn_slowpath_null+0x1c/0x24)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.212799] [<c0034f14>] (warn_slowpath_null) from [<bf0849fc>] (___ieee80211_stop_tx_ba_session+0x1e8/0x1f8 [mac80211])
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.223749] [<bf0849fc>] (___ieee80211_stop_tx_ba_session [mac80211]) from [<bf084df0>] (__ieee80211_stop_tx_ba_session+0x2c/0x40 [mac80211])
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.236527] [<bf084df0>] (__ieee80211_stop_tx_ba_session [mac80211]) from [<bf089174>] (ieee80211_iface_work+0x1c0/0x610 [mac80211])
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.248510] [<bf089174>] (ieee80211_iface_work [mac80211]) from [<c00494a4>] (process_one_work+0x228/0x3bc)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.258292] [<c00494a4>] (process_one_work) from [<c0049948>] (worker_thread+0x310/0x504)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.266505] [<c0049948>] (worker_thread) from [<c004e65c>] (kthread+0xf0/0xf8)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.273758] [<c004e65c>] (kthread) from [<c0009d38>] (ret_from_fork+0x14/0x3c)
Wed Nov  2 17:10:42 2016 kern.warn kernel: [74542.281021] ---[ end trace 09d229b863156d80 ]---
28.12.2016362Base systemBug ReportVery LowMediumWR1043ND v4 Slow WAN -> LAN Whilst Synced @100MbpsTrunkWaiting on reporter Task Description

Recently, builds for this device have started to be made, but there’s a very peculiar issue I’ve found. Any client that is synced to 100 Mbps (and not 1 Gbps, in my case due to incapacity of the cable used) gets their speed seemingly throttled to 20-30 Mbps. My connection is a 100 Mbps connection, and I get full 95 Mbps (Hardware NAT disabled) on the stock firmware, and I also get this speed on LEDE only if I use a 1 Gbps link.

Speedtest on the stock firmware with the 100 Mbps link: http://www.speedtest.net/result/5904234776.png Speedtest on the latest LEDE with the 100 Mbps link: http://www.speedtest.net/result/5915271748.png 1 Gbps links get full speed, as expected.

If I perform a transfer from LAN to LAN, I get full speed on the 100 Mbps link. The resulting speed graph is not a hard-cap, but seemingly some kind of throttle/flow control being applied. I cannot change any settings with ethtool as it throws ‘not supported’ errors.

Only happens WAN > LAN connections.
Nothing of interest in the logs, unless I can somehow get a more verbose log of the connection status.

06.02.2017472Base systemBug ReportVery LowMedium6to4 support with 1:1 natTrunkWaiting on reporter Task Description

One-to-one NAT means you have LAN address on interface and its mapped 1:1 to external ip addresses.
You can have incoming connections.

In such configuration “ipaddr” must be specified in 6to4 protocol section.
But due to bug this addr is submitted as local address for tunnel creation.
It does not work.

I fixed this with the following patch to /lib/netifd/proto/6to4.sh

48,53c48,53
< [ -z “$ipaddr” ] && {
< if ! network_get_ipaddr ipaddr “$wanif”; then
< proto_notify_error “$cfg” “NO_WAN_ADDRESS” < return
< fi
< }

if ! network_get_ipaddr ipladdr “$wanif”; then
> proto_notify_error “$cfg” “NO_WAN_ADDRESS”
return
> fi
>
> [ -z “$ipaddr” ] && ipaddr=$ipladdr
76c76
< json_add_string local “$ipaddr”

json_add_string local “$ipladdr”

I suggest you integrate this patch or do something similar yourself.

26.03.2017656Base systemBug ReportVery LowMediumIPv6 relay mode does not worklede-17.01Waiting on reporter Task Description

My ISP does not support DHCPv6, so I need to use IPv6 relay mode to enable my devices to obtain IPv6 addresses via SLAAC. I have configured relay mode as indicated in the documentation on a HooToo TM-02 for the time being. If I can get all this to work I will upgrade to a more capable device.

Running tcpdump on the WLAN interface I can see the router solicitation requests coming from my clients. When I run tcpdump on the WAN interface I don’t see any router solicitations and, therefore, no router advertisements coming back from my ISP modem. The router itself gets an address from the modem, but the relaying of requests from clients is not happening.

I have posted my config files below, but they are basically stock. Is this a problem with the DHCPv6 server or some kind of firewall problem preventing the requests from getting out?

/etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd20:0787:2c66::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option ip6assign '64'

config device 'lan_dev'
	option name 'eth0'
	option macaddr '00:1c:c2:13:6f:05'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth0'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth0'
	option reqaddress 'try'
	option reqprefix 'auto'

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'relay'
	option ra 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'wan6'
	option dhcpv6 'relay'
	option ra 'relay'
	option ndp 'relay'
	option master '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

/etc/config/firewall:

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config rule
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'
12.06.2017840Base systemBug ReportVery LowMediumAR71xx - Recent firmware won't flash (building without ...TrunkWaiting on reporter Task Description

Device: TP-Link TL-WR841N/ND v8

LEDE release: anything I tried after r4335

Steps to reproduce:

  1. Build: make defconfig, make menuconfig, specify target = TL-WR841N/ND v8, exit (save), make defconfig, make. Everything OK.
  2. Try to flash (I use LuCI). After the usual “don’t turn me off” screen, the router page reappears and the firmware hasn’t been updated. It’s still the previous version.


14.09.2016177Base systemBug ReportVery LowLowipq806x: USB3 ports fail if booted when USB3 flash driv...TrunkWaiting on reporter Task Description

I am seeing a strange problem on my new TRENDnet tew827dru, which is ipq8064 based. It has two USB3 ports.

I have noticed a problem with USB3 flash drives. If I boot the system with a USB3 flash drive in one of the USB ports, that port won’t allow any USB3 drive to work in it until the next reboot.

It seems to be a xhci driver issue.

This behavior is somewhat intermittent and varied. Occasionally my Silicon Power USB3 drive will work fine after boot, and the SanDisk USB3 drive almost always appears in “lsusb”, but the partitions can’t be seen, and it still doesn’t work right.

The USB3 flash drives works as-expected if I plug them in after boot is completed. The issue only appears if the drive was already in the USB port during boot time.

USB2 flash drives do not appear to be affected.

The USB3 hard drive I tested seems to be working normally.

USB flash drives tested:

  SanDisk Ultra Fit 16GB (USB3)
  Patriot Tab Series 32GB (USB3)
  Silicon Power 32GB (USB3)
  Kingston DTSE9 8GB (USB2)
  Patriot 8GB (USB2)

Below is an example boot log where I have a USB3 drive in each of the two ports. Neither works:

[ 6.275249] usbcore: registered new interface driver usbfs
[ 6.275322] usbcore: registered new interface driver hub
[ 6.279713] usbcore: registered new device driver usb
[ 6.320705] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 6.321204] ehci-platform: EHCI generic platform driver
[ 6.331613] ohci_hcd: USB 1.1 ‘Open’ Host Controller (OHCI) Driver
[ 6.332310] ohci-platform: OHCI generic platform driver
[ 6.841285] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 6.841329] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1
[ 6.845931] xhci-hcd xhci-hcd.0.auto: hcc params 0x0228f065 hci version 0×100 quirks 0×00010010 [ 6.853327] xhci-hcd xhci-hcd.0.auto: irq 200, io mem 0×11000000 [ 6.862602] hub 1-0:1.0: USB hub found
[ 6.872028] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 6.875912] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2
[ 6.881170] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 6.889250] hub 2-0:1.0: USB hub found
[ 6.900865] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 6.904684] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 3
[ 6.910066] xhci-hcd xhci-hcd.1.auto: hcc params 0x0228f065 hci version 0×100 quirks 0×00010010 [ 6.917541] xhci-hcd xhci-hcd.1.auto: irq 201, io mem 0×10000000 [ 6.926734] hub 3-0:1.0: USB hub found
[ 6.936227] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 6.940023] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 4
[ 6.945455] usb usb4: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 6.953458] hub 4-0:1.0: USB hub found
[ 6.965885] of_get_named_gpiod_flags: parsed ‘gpios’ property of node ‘/gpio-leds/usb[0]’ - status (0)
[ 6.967608] usbcore: registered new interface driver usb-storage
[ 7.182177] usb 1-1: new high-speed USB device number 2 using xhci-hcd
[ 7.252035] usb 3-1: new high-speed USB device number 2 using xhci-hcd
[ 7.382317] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 7.417343] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 7.428209] scsi host0: usb-storage 2-1:1.0
[ 7.442238] usb 4-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 7.465865] usb-storage 4-1:1.0: USB Mass Storage device detected
[ 7.466672] scsi host1: usb-storage 4-1:1.0
[ 8.462818] scsi 1:0:0:0: Direct-Access USB DISK 3.0 PMAP PQ: 0 ANSI: 6
[ 17.195224] xhci-hcd xhci-hcd.0.auto: xHCI host not responding to stop endpoint command.
[ 17.195259] xhci-hcd xhci-hcd.0.auto: Assuming host is dying, halting host.
[ 17.227985] xhci-hcd xhci-hcd.0.auto: Host not halted after 16000 microseconds.
[ 17.228010] xhci-hcd xhci-hcd.0.auto: Non-responsive xHCI host is not halting.
[ 17.234094] xhci-hcd xhci-hcd.0.auto: Completing active URBs anyway.
[ 17.241418] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up
[ 17.248041] usb usb1-port1: couldn’t allocate usb_device
[ 17.253296] usb 2-1: USB disconnect, device number 2
[ 17.263718] xhci-hcd xhci-hcd.1.auto: xHCI host not responding to stop endpoint command.
[ 17.263722] xhci-hcd xhci-hcd.1.auto: Assuming host is dying, halting host.
[ 17.289471] xhci-hcd xhci-hcd.1.auto: Host not halted after 16000 microseconds.
[ 17.289481] xhci-hcd xhci-hcd.1.auto: Non-responsive xHCI host is not halting.
[ 17.289491] xhci-hcd xhci-hcd.1.auto: Completing active URBs anyway.
[ 17.289534] xhci-hcd xhci-hcd.1.auto: HC died; cleaning up
[ 17.324608] usb usb3-port1: couldn’t allocate usb_device
[ 17.329821] usb 4-1: USB disconnect, device number 2

And here I am plugging both drives in after the system booted normally.

[ 6.193094] usbcore: registered new interface driver usbfs
[ 6.193173] usbcore: registered new interface driver hub
[ 6.197552] usbcore: registered new device driver usb
[ 6.238600] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 6.239108] ehci-platform: EHCI generic platform driver
[ 6.249525] ohci_hcd: USB 1.1 ‘Open’ Host Controller (OHCI) Driver
[ 6.250089] ohci-platform: OHCI generic platform driver
[ 6.761332] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 6.761378] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1
[ 6.765992] xhci-hcd xhci-hcd.0.auto: hcc params 0x0228f065 hci version 0×100 quirks 0×00010010 [ 6.773385] xhci-hcd xhci-hcd.0.auto: irq 200, io mem 0×11000000 [ 6.782646] hub 1-0:1.0: USB hub found
[ 6.792070] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 6.795937] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2
[ 6.801200] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 6.809293] hub 2-0:1.0: USB hub found
[ 6.820906] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 6.824739] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 3
[ 6.830118] xhci-hcd xhci-hcd.1.auto: hcc params 0x0228f065 hci version 0×100 quirks 0×00010010 [ 6.837600] xhci-hcd xhci-hcd.1.auto: irq 201, io mem 0×10000000 [ 6.846784] hub 3-0:1.0: USB hub found
[ 6.856269] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 6.860070] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 4
[ 6.865495] usb usb4: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 6.873508] hub 4-0:1.0: USB hub found
[ 6.885940] of_get_named_gpiod_flags: parsed ‘gpios’ property of node ‘/gpio-leds/usb[0]’ - status (0)
[ 27.122596] usb 4-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 27.144608] usb-storage 4-1:1.0: USB Mass Storage device detected
[ 27.155356] scsi host0: usb-storage 4-1:1.0
[ 28.153237] scsi 0:0:0:0: Direct-Access USB DISK 3.0 PMAP PQ: 0 ANSI: 6
[ 30.753700] usb 2-1: new SuperSpeed USB device number 2 using xhci-hcd
[ 30.776011] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 30.776282] scsi host1: usb-storage 2-1:1.0

24.09.2016185Base systemBug ReportVery LowLow50% packet loss on LAN interface on Netgear R8000TrunkWaiting on reporter Task Description

Hi -

I am on the R8000 and have seen this issue across all builds I’ve tried for the last two months, and as far as I know this has been present forever. The device is connected on IPv4 with VLAN tagging to my ISP using PPPOE. The packet loss being seen is from a hardwired device, and this packet loss can be replicated on any port and with other devices. Attached is a PingPlotter output showing the packet loss. I tried disabling the syn rule in iptables, as I initially suspected that might be the cause. Right now, I am running:
Model Netgear R8000 (BCM4709)
Firmware Version LEDE Reboot r1597 / LuCI Master (git-16.266.66957-07591d7)
Kernel Version 4.4.19

I am happy to provide ANY additional information you required. I am an open source dev for Android and I TRULY APPRECIATE what you guys are doing here.

28.02.2017565Base systemBug ReportVery LowLowcrash in MT7603ETrunkWaiting on reporter Task Description

Supply the following if possible:
- Device problem occurs on
zbt wg3526
- Software versions of LEDE release, packages, etc.
17.01.0
- Steps to reproduce
just boot and try to use the 2.4ghz. you will see a crash like
– (wlan0-1) entered forwarding state
[ 26.300000] ————[ cut here ]———— [ 26.300000] WARNING: CPU: 0 PID: 22 at
/build/lede-17.01/slaves/phase1/ramips_mt7621/build/build_dir/target-mipsel_24kc_musl-1.1.16/linux-ramips_mt7621/mt76-2017-01-31-3c8caafc/mt7603_mac.c:1207
0x8f20d31c [mt7603e@8f208000+0x68a0]()
[ 26.320000] Modules linked in: pppoe ppp_async iptable_nat pppox
ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT
ipt_MASQUERADE xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark
xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG
xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat
nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache
nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt
ledtrig_usbport mt7603e mt76x2e mt76 mac80211 cfg80211 compat
ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle
ip6table_filter ip6_tables x_tables leds_gpio xhci_mtk xhci_plat_hcd
xhci_pci xhci_hcd ahci libahci libata sd_mod scsi_mod
gpio_button_hotplug usbcore nls_base usb_common
[ 26.390000] CPU: 0 PID: 22 Comm: kworker/u8:1 Not tainted 4.4.50 #0
[ 26.390000] Workqueue: phy1 0x8f20d11c [mt7603e@8f208000+0x68a0]
[ 26.390000] Stack : 8fce5080 80420000 803a293c 000004b7 00000000
00000000 00000000 00000000
[ 26.390000] 00000000 00000000 00000000 00000000 00000000 00000000
00000000 00000000
[ 26.390000] 00000000 00000000 00000000 00000000 00000000 00000000
00000000 00000000
[ 26.390000] 00000000 00000000 00000000 00000000 00000000 00000000
00000000 00000000
[ 26.390000] 00000000 00000000 00000000 00000000 00000000 00000000
00000000 00000000
[ 26.390000] ...
[ 26.390000] Call Trace:[<80016448>] 0×80016448 [ 26.390000] [<80016448>] 0×80016448 [ 26.390000] [<801b4160>] 0x801b4160
[ 26.390000] [<8002bf50>] 0x8002bf50
[ 26.390000] [<8f20d31c>] 0x8f20d31c [mt7603e@8f208000+0x68a0]
[ 26.390000] [<8002c008>] 0x8002c008
[ 26.390000] [<8f20d31c>] 0x8f20d31c [mt7603e@8f208000+0x68a0]
[ 26.390000] [<8000bea0>] 0x8000bea0
[ 26.390000] [<8003f100>] 0x8003f100
[ 26.390000] [<8003fffc>] 0x8003fffc
[ 26.390000] [<8003fd24>] 0x8003fd24
[ 26.390000] [<8003fd24>] 0x8003fd24
[ 26.390000] [<800447ac>] 0x800447ac
[ 26.390000] [<800446d4>] 0x800446d4
[ 26.390000] [<80005478>] 0×80005478 [ 26.390000]
[ 26.500000] —[ end trace 8c359128f05273c0 ]— — them some minutes later the wlan stops completely.

The problem also exists in the latest snapshots.

 


03.03.2017588Base systemBug ReportMediumLowopenvpn-mbedtls crash on mpc85xx with signal 4 (SIGILL)lede-17.01Waiting on reporter Task Description

device: tp-link wdr4900
affected version: lede 17.01 / openvpn-mbedtls - 2.4.0-3

openvpn config:

dev tun-monitoring
remote somehost 1194

ca /etc/openvpn/monitoring-vpn/ca.crt
cert /etc/openvpn/monitoring-vpn/xyz.crt
key /etc/openvpn/monitoring-vpn/xyz.key
tls-auth /etc/openvpn/monitoring-vpn/ta.key 1
remote-cert-tls server

keepalive 10 120
cipher AES-256-CBC
comp-lzo yes

persist-key
persist-tun


14.05.2017784ToolchainBug ReportVery LowLowar71xx: imagebuilder fails when BIN_DIR or EXTRA_IMAGE_...lede-17.01Waiting on reporter Task Description

Supply the following if possible:

- Device problem occurs on

HORNETUBx2

HORNETUB

- Software versions of LEDE release, packages, etc.

lede-imagebuilder-17.01.1-ar71xx-generic.Linux-x86_64

- Steps to reproduce

make image PROFILE=HORNETUBx2 BIN_DIR=/tmp/bld/

... dies with :

“Warning: /home/kjh/toolroot.d/lede-imagebuilder-17.01.1-ar71xx-generic.Linux-x86_64/bin/targets/ar71xx/generic/lede-17.01.1-ar71xx-generic-hornet-ub-x2-squashfs-sysupgrade.bin is too big (> 16318464 bytes)”

... but it seems to work OK without BIN_DIR :

make image PROFILE=HORNETUBx2

EXTRA_IMAGE_NAME also seems to cause this problem


24.06.2017866Base systemBug ReportVery LowLowThe DownloadMethod/hg in include/download.mk seems to b...AllWaiting on reporter Task Description

This is a build issue for packages which are using the Mercurial (hg) source code control system. The DownloadMethod/hg tries to re-stamp the files, but the method to do so seems insufficient.

My current fix is this one (without any claim of correctness or completeness), it allows me to make the builds as before the timestamping change was implemented.

— a/include/download.mk
+++ b/include/download.mk
@@ -198,7 +198,7 @@ define DownloadMethod/hg

              rm -rf $(SUBDIR) && \
              [ \! -d $(SUBDIR) ] && \
              hg clone -r $(VERSION) $(URL) $(SUBDIR) && \

- export TAR_TIMESTAMP=`cd $(SUBDIR) && hg log –template ‘@{date}’ -l 1` && \
+ export TAR_TIMESTAMP=`cd $(SUBDIR) && hg log –template ‘@{date}’ -l 1 | cut -d’.’ -f1` && \

This is with Mercurial 3.7.3 (default Mercurial in Ubuntu 16.04.2)


03.07.2017882Base systemBug ReportVery LowLowDSL-2750B hw. D1 repeatedly rebootsTrunkWaiting on reporter Task Description

Supply the following if possible:
- DSL-2750B hw D1
- Latest snapshot build
- Steps to reproduce: simply upload and flash latest firmware from CFE web interface and wait for its reboot.
Device never stop to reboot repeatedly.

 


17.07.2017911OtherBug ReportVery LowLowProblem with login into private git reposAllWaiting on reporter Task Description

I am not able to use packages from my private git repos which needs login. The system during the build process don’t ask me for login as before.

Here is the verbose log output:

make[3]: Leaving directory `/home/flowtester/caes/platform/package/base-files'
make[3]: Entering directory `/home/flowtester/caes/platform/package-bumblebee/packages/libdevereader'
mkdir -p /home/flowtester/caes/platform/dl
SHELL= flock /home/flowtester/caes/platform/tmp/.libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860.tar.gz.flock -c '          echo "Checking out files from the git repository..."; mkdir -p /home/flowtester/caes/platform/tmp/dl && cd /home/flowtester/caes/platform/tmp/dl && rm -rf libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 && [ \! -d libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 ] && git clone  https://redmine.develict.com/git/devereader libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 && (cd libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 && git checkout daa94e0fad44a000892570665e6c792fd9cad860 && git submodule update --init --recursive) && echo "Packing checkout..." && export TAR_TIMESTAMP=`cd libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 && git log -1 --format='\''@%ct'\''` && rm -rf libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860/.git &&  tar --numeric-owner --owner=0 --group=0 --sort=name ${TAR_TIMESTAMP:+--mtime="$TAR_TIMESTAMP"} -c libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860 |     gzip -nc > /home/flowtester/caes/platform/tmp/dl/libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860.tar.gz && mv /home/flowtester/caes/platform/tmp/dl/libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860.tar.gz /home/flowtester/caes/platform/dl/ && rm -rf libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860;     '
Checking out files from the git repository...
Cloning into 'libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860'...
fatal: Authentication failed for 'https://redmine.develict.com/git/devereader/'
make[3]: *** [/home/flowtester/caes/platform/dl/libdevereader-1.1.7-daa94e0fad44a000892570665e6c792fd9cad860.tar.gz] Error 128
make[3]: Leaving directory `/home/flowtester/caes/platform/package-bumblebee/packages/libdevereader'
make[2]: *** [package/feeds/bumblebee/libdevereader/compile] Error 2
make[2]: Leaving directory `/home/flowtester/caes/platform'
make[1]: *** [/home/flowtester/caes/platform/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/flowtester/caes/platform'
make: *** [world] Error 2

If I try it manually from cli everythings works but not during the prepare process ....


25.07.2017932KernelBug ReportVery LowLowTP-Link WR841N: mixed VLANs on the same portTrunkWaiting on reporter Task Description

Hi,
i have several TP-Link WR841N v9/v10/v11 running LEDE trunk. Configuring tagged and untagged VLANs on the same port fails.

cat /etc/config/network
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t 2t 3t 4t'
        option vid '2'

swconfig dev switch0 show
    Global attributes:
            enable_vlan: 1
    Port 0:
            pvid: 1
            link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
    Port 1:
            pvid: 1
            link: port:1 link:down
    Port 2:
            pvid: 1
            link: port:2 link:down
    Port 3:
            pvid: 1
            link: port:3 link:down
    Port 4:
            pvid: 1
            link: port:4 link:up speed:100baseT full-duplex auto
    VLAN 1:
            vid: 1
            ports: 0t 1t 2t 3t 4t
    VLAN 2:
            vid: 2
            ports: 0t 1t 2t 3t 4t
16.10.20171065Base systemBug ReportVery LowLow6to4 INVALID_LOCAL_ADDRESS protocol reconfiguration lo...TrunkWaiting on reporter Task Description

Reboot (SNAPSHOT, r5049-efbd4e7)

When 6to4 interface is up and wan receives LAN address (10.x,192.168.x)
100% cpu consuming loop happens. Netifd starts again and again configuration script.
Its likely more paths exist to reproduce same problem.
every proto_notify_error + return can cause netifd to restart proto setup immediately

14.10.2016227Base systemBug ReportMediumHighVLAN support mismatch between preinit and default netwo...TrunkResearching Task Description

PPPoE is broken on WRT1900ACS

Upgraded from Lede r578 to latest Lede r1814 and PPPOE doesn’t work anymore altough the pppd version and PPPoE version are the same:
- Linksys WRT1900ACS
- LEDE reboot r1814

pppd debug log:

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Timeout waiting for PADO packets
Unable to complete PPPoE Discovery
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]

While on the same hardware running LEDE r578, the PPPoE module works as expected:

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0×0 length 4
dst ff:ff:ff:ff:ff:ff src c2:56:27:ca:d7:d4
[service-name]
Recv PPPOE Discovery V1T1 PADO session 0×0 length 40
dst c2:56:27:ca:d7:d4 src a0:f3:e4:34:d8:21
[service-name] [AC-name acc-aln1.hac] [AC-cookie 75 58 37 a5 ba 3c e4 a5 2a 61 bb 23 92 5c 1b dc]
Send PPPOE Discovery V1T1 PADR session 0×0 length 24
dst a0:f3:e4:34:d8:21 src c2:56:27:ca:d7:d4
[service-name] [AC-cookie 75 58 37 a5 ba 3c e4 a5 2a 61 bb 23 92 5c 1b dc]
Recv PPPOE Discovery V1T1 PADS session 0x30b length 4
dst c2:56:27:ca:d7:d4 src a0:f3:e4:34:d8:21
[service-name]
PADS: Service-Name: ‘’ PPP session is 779
Connected to a0:f3:e4:34:d8:21 via interface eth0
using channel 2
Using interface pppoe-wan
Connect: pppoe-wan ←→ eth0
sent [LCP ConfReq id=0×1 <mru 1492> <magic 0xc6952556>]
rcvd [LCP ConfReq id=0×66 <mru 1492> <auth chap MD5> <magic 0x4cc73648>]
sent [LCP ConfAck id=0×66 <mru 1492> <auth chap MD5> <magic 0x4cc73648>]
rcvd [LCP ConfAck id=0×1 <mru 1492> <magic 0xc6952556>]
sent [LCP EchoReq id=0×0 magic=0xc6952556]
rcvd [CHAP Challenge id=0×1 <7131a44524d1de8f1cd1061cac6d8c071d8bfe7351bc4ea7bd08f56684428475f229ba177a192696ebab32>, name = “acc-aln1.hac”]
sent [CHAP Response id=0×1 <4bb1a418b298790b128ad4d7ef3109ad>, name = “bthomehub@btbroadband.com”]
rcvd [LCP EchoRep id=0×0 magic=0x4cc73648]
rcvd [CHAP Success id=0×1 “CHAP authentication success”]
CHAP authentication succeeded: CHAP authentication success
CHAP authentication succeeded
peer from calling number A0:F3:E4:34:D8:21 authorized
sent [IPCP ConfReq id=0×1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPV6CP ConfReq id=0×1 <addr fe80::c595:37d1:3987:1929>]
rcvd [IPV6CP ConfReq id=0x7b <addr fe80::0221:05ff:feb4:8824>]
sent [IPV6CP ConfAck id=0x7b <addr fe80::0221:05ff:feb4:8824>]
rcvd [IPCP ConfReq id=0×38 <addr 172.16.12.12>]
sent [IPCP ConfAck id=0×38 <addr 172.16.12.12>]
rcvd [IPCP ConfNak id=0×1 <addr 81.146.2.155> <ms-dns1 81.139.57.100> <ms-dns2 81.139.56.100>]
sent [IPCP ConfReq id=0×2 <addr 81.146.2.155> <ms-dns1 81.139.57.100> <ms-dns2 81.139.56.100>]
rcvd [IPV6CP ConfAck id=0×1 <addr fe80::c595:37d1:3987:1929>]
local LL address fe80::c595:37d1:3987:1929
remote LL address fe80::0221:05ff:feb4:8824
Script /lib/netifd/ppp-up started (pid 2646)
rcvd [IPCP ConfAck id=0×2 <addr 81.146.2.155> <ms-dns1 81.139.57.100> <ms-dns2 81.139.56.100>]
local IP address 81.146.2.155
remote IP address 172.16.12.12
primary DNS address 81.139.57.100
secondary DNS address 81.139.56.100
ppp.log
secondary DNS address 81.139.56.100
Script /lib/netifd/ppp-up started (pid 2653)
Script /lib/netifd/ppp-up finished (pid 2646), status = 0×9 Script /lib/netifd/ppp-up finished (pid 2653), status = 0×9

01.06.2017822Base systemBug ReportMediumHighbusybox (ash) sporadically segfaults running shell scri...lede-17.01Researching Task Description

I’m often seeing this message in my logs:

[ 2183.499756] do_page_fault(): sending SIGSEGV to dhcpv6.script for invalid read access from 00000000    
[ 2183.509195] epc = 0041efe9 in busybox[400000+4b000]                                                    
[ 2183.514285] ra  = 0041efb1 in busybox[400000+4b000]                                                    

The issue might be a new variant of  FS#251 , which disappeared after a busybox upgrade.

I’m on a recent lede-17.01 version (dfecce60e6e75abf3ea817fe7bf29fd432693f13), with the follow adjustments to busybox:

CONFIG_BUSYBOX_CUSTOM=y
# CONFIG_BUSYBOX_CONFIG_FEATURE_PREFER_IPV4_ADDRESS is not set

Hardware: TP-Link TL-WR841ND v9 (QCA9533)

My analysis so far:

Registers:

          zero       at       v0       v1       a0       a1       a2       a3
 R0   00000000 7fcfd4c8 00000000 0090b7c0 00910df4 00910df9 2f2f2f2f bcd0a2f0 
            t0       t1       t2       t3       t4       t5       t6       t7
 R8   fefefeff 80808080 80083c3c 002f3634 7fcf9698 00000000 00000000 77a6e2c0 
            s0       s1       s2       s3       s4       s5       s6       s7
 R16  0090ccc0 7fcf9900 00000004 0040788d 77a64000 77a64000 77a67518 77a68d8c 
            t8       t9       k0       k1       gp       sp       s8       ra
 R24  0045b0e8 77a36d44 00000000 00000000 77a6e2c0 7fcf97d0 00000000 0041efb1 
            sr       lo       hi      bad    cause       pc
      0000f413 00000048 00000013 00000000 00800008 0041efe9 
           fsr      fir
      00000000 00000000 

Disassembly:

Dump of assembler code for function find_command:                                                         
   0x0041ef45 <+0>:     save    a0-a3,232,ra,s0-s1                                                        
   0x0041ef49 <+4>:     move    s1,a1                                                                     
   0x0041ef4b <+6>:     jal     0x449c61 <strchr@mips16plt>                                               
   0x0041ef4f <+10>:    li      a1,47
   0x0041ef51 <+12>:    beqz    v0,0x41ef79 <find_command+52>
   0x0041ef53 <+14>:    li      v0,1
   0x0041ef55 <+16>:    neg     v0
   0x0041ef57 <+18>:    lw      v1,240(sp)
   0x0041ef59 <+20>:    sw      v0,4(s1)
   0x0041ef5b <+22>:    li      v0,2
   0x0041ef5d <+24>:    and     v0,v1
   0x0041ef5f <+26>:    bnez    v0,0x41ef65 <find_command+32>
   0x0041ef61 <+28>:    li      v0,0
   0x0041ef63 <+30>:    b       0x41ef75 <find_command+48>
   0x0041ef65 <+32>:    lw      a0,232(sp)
   0x0041ef67 <+34>:    jal     0x44a441 <stat@mips16plt>
   0x0041ef6b <+38>:    addiu   a1,sp,56
   0x0041ef6d <+40>:    slti    v0,0
   0x0041ef6f <+42>:    bteqz   0x41ef61 <find_command+28>
   0x0041ef71 <+44>:    li      v0,1
   0x0041ef73 <+46>:    neg     v0
   0x0041ef75 <+48>:    sb      v0,0(s1)
   0x0041ef77 <+50>:    b       0x41f1af <find_command+618>
   0x0041ef79 <+52>:    lw      v0,0x41f1b4 <find_command+623>
   0x0041ef7b <+54>:    lw      a0,244(sp)
   0x0041ef7d <+56>:    lw      v0,0(v0)
   0x0041ef7f <+58>:    addiu   v0,124
   0x0041ef81 <+60>:    lw      v0,88(v0)
   0x0041ef83 <+62>:    addiu   v0,5
   0x0041ef85 <+64>:    xor     v0,a0
   0x0041ef87 <+66>:    sltiu   v0,1
   0x0041ef89 <+68>:    move    v1,t8
   0x0041ef8b <+70>:    sw      v1,40(sp)
   0x0041ef8d <+72>:    beqz    v0,0x41efa9 <find_command+100>
   0x0041ef8f <+74>:    lw      v0,240(sp)
   0x0041ef91 <+76>:    li      s0,8
   0x0041ef93 <+78>:    lw      a1,0x41f1b8 <find_command+627>
   0x0041ef95 <+80>:    jal     0x449ba1 <strstr@mips16plt>
   0x0041ef99 <+84>:    or      s0,v0
   0x0041ef9b <+86>:    beqz    v0,0x41efa7 <find_command+98>
   0x0041ef9d <+88>:    lw      v1,240(sp)
   0x0041ef9f <+90>:    li      v0,40
   0x0041efa1 <+92>:    or      v1,v0
   0x0041efa3 <+94>:    sw      v1,240(sp)
   0x0041efa5 <+96>:    b       0x41efa9 <find_command+100>
   0x0041efa7 <+98>:    sw      s0,240(sp)
   0x0041efa9 <+100>:   lw      a0,232(sp)
   0x0041efab <+102>:   jal     0x41a75d <cmdlookup>
   0x0041efaf <+106>:   li      a1,0
   0x0041efb1 <+108>:   move    s0,v0
   0x0041efb3 <+110>:   beqz    v0,0x41efdd <find_command+152>
   0x0041efb5 <+112>:   lb      v0,8(v0)
   0x0041efb7 <+114>:   cmpi    v0,1
   0x0041efb9 <+116>:   bteqz   0x41efc3 <find_command+126>
   0x0041efbb <+118>:   cmpi    v0,2
   0x0041efbd <+120>:   btnez   0x41efc7 <find_command+130>
   0x0041efbf <+122>:   li      v0,32
   0x0041efc1 <+124>:   b       0x41efc9 <find_command+132>
   0x0041efc3 <+126>:   li      v0,4
   0x0041efc5 <+128>:   b       0x41efc9 <find_command+132>
   0x0041efc7 <+130>:   li      v0,8
   0x0041efc9 <+132>:   lw      v1,240(sp)
   0x0041efcb <+134>:   and     v0,v1
   0x0041efcd <+136>:   bnez    v0,0x41efd7 <find_command+146>
   0x0041efcf <+138>:   lbu     v0,9(s0)
   0x0041efd1 <+140>:   beqz    v0,0x41f1a3 <find_command+606>
   0x0041efd5 <+144>:   b       0x41efdd <find_command+152>
   0x0041efd7 <+146>:   li      v0,0
   0x0041efd9 <+148>:   li      s0,0
   0x0041efdb <+150>:   sw      v0,40(sp)
   0x0041efdd <+152>:   jal     0x41b025 <find_builtin>
   0x0041efe1 <+156>:   lw      a0,232(sp)
   0x0041efe3 <+158>:   sw      v0,44(sp)
   0x0041efe5 <+160>:   beqz    v0,0x41f00f <find_command+202>
   0x0041efe7 <+162>:   lw      v0,0(v0)
=> 0x0041efe9 <+164>:   lbu     v1,0(v0)
   0x0041efeb <+166>:   li      v0,2
   0x0041efed <+168>:   and     v0,v1
   0x0041efef <+170>:   bnez    v0,0x41f177 <find_command+562>
   0x0041eff3 <+174>:   lw      v1,240(sp)
   0x0041eff5 <+176>:   li      v0,8
   0x0041eff7 <+178>:   and     v0,v1
   0x0041eff9 <+180>:   beqz    v0,0x41f005 <find_command+192>
   0x0041effb <+182>:   li      v0,32
   0x0041effd <+184>:   and     v0,v1
   0x0041efff <+186>:   beqz    v0,0x41f177 <find_command+562>
   0x0041f003 <+190>:   b       0x41f00f <find_command+202>
   0x0041f005 <+192>:   lw      v0,0x41f1bc <find_command+631>
   0x0041f007 <+194>:   lw      v0,0(v0)
...

As in  FS#251 , the contents of the registers don’t really make sense. Unless I’m overlooking something, it should not be possible for $pc to reach 0x0041efe9 with $ra on 0x0041efb1 (return from cmdlookup); rather, $ra should have the value 0x0041efe3 (return from find_builtin). There are no code paths reaching 0x0041efe9 that don’t call find_builtin.

25.07.2017929KernelBug ReportVery LowHighmt7620 abysmal wifi performanceAllResearching Task Description

HT40 wifi throughput went from ~80 Mbps(LEDE 17.01.0) to ~3Mpbs (since LEDE 17.01.2 to trunk, 17.01.1 wouldn’t build).
HT20 decreased from ~40 to ~10 Mbps.

device is archer C20i (mt7620a) on 2.4 GHz band, 5 Ghz is unsupported (mt7610E).

Log errors:

[    9.197616] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
[    9.205560] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected
[  304.206295] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[  304.278242] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[  306.059378] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2
15.05.2017786Base systemFeature RequestVery LowMediumPlease, add support to ecdsa key typelede-17.01Researching Task Description

At the moment dropbear tool is compiled without the ecdsa key type support.
ECDSA (https://en.wikipedia.org/wiki/Elliptic_Curve_Digital_Signature_Algorithm) is considere better than RSA as it requires fewer key bits to gain same security.

22.06.201626FlysprayFeature RequestVery LowLowComment formatting syntax should be documentedTrunkResearching Task Description

Currently the formatting options are not documented anywhere, and I failed to find any documentation with google. There are a few buttons to use, but they seem to be rather limited (e.g. nothing for quotations).

17.04.2017713Base systemBug ReportVery LowLownetifd: substantially more IFUP events are being create...TrunkResearching Task Description

I have noticed that some services reloaded with a procd “interface.*” raw trigger are reloading on a much more frequent cadence (few minutes or so). LEDE 17.01 does not do this. LEDE Trunk does. I can not find an obvious cause in procd. Though procd should not stop-start for reload without a command line change or explicit file under watch. Perhaps netifd commit a03216660797173fbe67866f75564e3fec9c1e8d is generating unusual numbers of IFUP.

procd_add_raw_trigger “interface.*” 2000 /etc/init.d/[script] reload

15.07.2017908KernelBug ReportMediumLowx86: Xen support broken in 17.01.2 and laterlede-17.01Researching Task Description

Testing the x86/generic image with Xen 4.5:

  • 17.01.0: works
  • 17.01.1: works
  • 17.01.2: fails to boot
  • latest lede-17.01 r3466-f6907dcc79: fails to boot
  • latest trunk r4553-a89c36b: works

When the kernel fails to boot, xl prints this:

xc: error: elf_xen_note_check: ERROR: Will only load images built for the generic loader or Linux images (Not '' and ''): Invalid kernel
libxl: error: libxl_dom.c:414:libxl__build_pv: xc_dom_parse_image failed: No such file or directory
libxl: error: libxl_create.c:1024:domcreate_rebuild_done: cannot (re-)build domain: -3

It means that the kernel image has no Xen support (or there is an issue with the support).

Given the changes between 17.01.1 and 17.01.2, I think the patch adding PAE support may be responsible.

This was first reported in FS#787.

29.09.20171024PackagesFeature RequestVery LowLowThere is no "LEDE interface" for the Linux interface cr...AllResearching Task Description

Let’s say I want to enable dropbear only in the tun0 interface created by OpenVPN. The dropbear configuration has an “Interface” field where I can make it listen, for example, only on the “wan” or “lan” interfaces. But the tun0 interface has not been created by anything in /etc/config/network and LEDE doesn’t really know about it, so I can’t specify it the dropbear configuration.

Even adding the tun0 interface to a “vpn” network in /etc/config/network using “proto none” fails to do the trick.

24.07.2017927Base systemBug ReportVery LowCriticalSQUASHFS error: xz decompression failedlede-17.01Assigned Task Description

Ubiquiti AirGateway and Bullet M2
LEDE 17.01.2
Lighttpd
PHP7

Runs very well on boot up. Then after some interval ranging from minutes to days, the following typical error occurs, repeated numerous times with differing blocks:
Mon Jul 24 07:09:39 2017 kern.err kernel: [43650.730023] SQUASHFS error: xz decompression failed, data probably corrupt
Mon Jul 24 07:09:39 2017 kern.err kernel: [43650.735459] SQUASHFS error: squashfs_read_data failed to read block 0x1e5d9a

Following this the unit becomes unresponsive, very slow or reboots its self.
Tried on two different devices and get the same result.

Images produced with Imagebuilder with ipv6, usb, ppp, luci removed to give space on flash.

The exact same config on OpenWrt CC (but with php5) gives no problems.

root@BlueWave:~# free

           total       used       free     shared    buffers     cached

Mem: 28176 19956 8220 132 1460 4296
-/+ buffers/cache: 14200 13976
Swap: 0 0 0

root@BlueWave:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 4.8M 4.8M 0 100% /rom
tmpfs 13.8M 132.0K 13.6M 1% /tmp
/dev/mtdblock5 1.4M 508.0K 964.0K 35% /overlay
overlayfs:/overlay 1.4M 508.0K 964.0K 35% /
tmpfs 512.0K 0 512.0K 0% /dev


19.02.2017534Base systemBug ReportVery LowHighUSB xHCI deadlock on bootlede-17.01Assigned Task Description

Supply the following if possible:
- Device problem occurs on
VirtualBox x86_64 Version 5.0.32 r112930
- Software versions of LEDE release, packages, etc.
17.01.00rc2
- Steps to reproduce
Create the disk image
Switch from EHCI (the default in a new VM) to xHCI.
Boot the machine
The machine will deadlock soon after initializing the USB ports


20.08.2016105Base systemBug ReportMediumMediumlantiq: high latency on adsl lines using pppo[ae]TrunkAssigned Task Description

based on the thread
[LEDE-DEV] [OpenWrt-Devel] latency on PPPoA ADSL Annex A on using Lantiq

http://lists.infradead.org/pipermail/lede-dev/2016-August/002138.html

When using ssh onto the box via adsl, there is a high latency.
The last 3.18 version of lede works. Known good:

  • 161179f40bd7899516518f3844fea28c6dd86efc r47130

Known broken versions:

  • 2795592d913ba8ba57ba537d40714407ea463426 r47131
  • 2a0e1b7f8d59f795abb29d20007822f0da232c43 r47958

mkresin also has a patch for lantiq+4.0, which also has a high latency.
blogic mentioned linux commit 7424ce65065852bdf7a040bf2490da4a8fc4b464 [atm] switch vcc_sendmsg() to copy_from_iter() could be the issue.

Also an interesting side-effect. setup a uhttpd on the device and serve a file to the internet is very slow (using 4mb file random data). it only uploads 5kb/s

12.02.2017503KernelBuild FailureVery LowMediumBuild fails with CONFIG_KERNEL_GIT_CLONE_URI beig setAllAssigned Task Description

When specifying

CONFIG_KERNEL_GIT_CLONE_URI

a clean build fails, as the system assumes a already downloaded/cloned/packed linux-source is present in dl/ which on a freshly checked out openwrt/lede source isn’t the case yet, when

toolchain/kernel-headers

is about to be built.

The build error looks like:

make[3]: Entering directory `/build/lede.git/toolchain/kernel-headers'
zcat /build/lede.git/dl/linux-4.4.42.tar.gz | tar -C /build/lede.git/build_dir/toolchain-arm_cortex-a9+neon_gcc-6.3.0_glibc-2.24_eabi -xf -
gzip: /build/lede.git/dl/linux-4.4.42.tar.gz: No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

The issue apparently is located in

include/kernel-defaults.mk

, line 53ff::

  ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
    define Kernel/Prepare/Default
        zcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
        $(Kernel/Patch)
        $(if $(QUILT),touch $(LINUX_DIR)/.quilt_used)
    endef
  else
    define Kernel/Prepare/Default
        zcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
    endef
  endif

For the package

kernel-headers

it just tries to access the not-yet downloaded/cloned/packed linux kernel source archive.

08.04.2017692Base systemBug ReportMediumMediumWLAN AP not working on RasPi (bcm2710 target)TrunkAssigned Task Description

When flashing the brcm2708 / bcm2710 target the WiFi interface gets stuck in “client mode” and the AP will not be able to be brought up.

Some screenshots and a load of discussion here:
https://forum.lede-project.org/t/ap-mode-radio0-in-raspi-3-always-acts-as-a-client-shows-as-wlan0-in-luci/2885

Two more days of tinkering, wifi-up’ing and -down’ing did not bring me further.
I flashed another Pi3 (to exclude a hardware defect) with the same result.

I tried latest snapshot and stable images.
I am happy to help debug – tell me what you need me to do.

Greetings,
–Thomas

11.04.2017704Base systemBug ReportMediumMediumbrcmfmac / Raspberry Pi 3 / wifi not working / adhoc an...TrunkAssigned Task Description

tested with a snapshot-image and a selfcompiled with r3923
wifi in adhoc mode or 80211s-mode ist not working. Messages in
syslog are the same. wifi-scanning works (iw dev wlan0 scan).

root@LEDE:~ :) dmesg | grep -i brcm
[   14.341639] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Aug 29 2016 20:48:16 version 7.45.41.26 (r640327) FWID 01-4527cfab
[   14.387220] usbcore: registered new interface driver brcmfmac

root@LEDE:~ wifi
root@LEDE:~ logread
Sun Apr  9 04:04:02 2017 daemon.notice netifd: Interface 'wlan' is now down
Sun Apr  9 04:04:02 2017 daemon.notice netifd: Interface 'wlan' is disabled
Sun Apr  9 04:04:03 2017 daemon.notice netifd: radio0 (5094): command failed: No error information (-524)
Sun Apr  9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: No error information (-524)
Sun Apr  9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: Not supported (-95)
Sun Apr  9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: I/O error (-5)
Sun Apr  9 04:04:03 2017 daemon.notice netifd: radio0 (5131): command failed: Too many open files in system (-23)
Sun Apr  9 04:04:04 2017 daemon.notice netifd: radio0 (5131): command failed: Too many open files in system (-23)
Sun Apr  9 04:04:04 2017 daemon.notice netifd: radio0 (5131): Device setup failed: INTERFACE_CREATION_FAILED
Sun Apr  9 04:04:04 2017 daemon.notice netifd: radio0 (5131): WARNING: Variable 'interfaces' does not exist or is not an array/object

root@LEDE:~ uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.country='US'
wireless.radio0.channel='5'
wireless.radio0.path='platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
wireless.radio0.hwmode='11g'
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device='radio0'
wireless.@wifi-iface[0].network='wlan'
wireless.@wifi-iface[0].mode='adhoc'
wireless.@wifi-iface[0].bssid='02:ca:ff:ee:ba:be'
wireless.@wifi-iface[0].macaddr='b8:27:eb:14:63:ea'
wireless.@wifi-iface[0].ssid='ffintern.2GHz'

root@LEDE:~ :) ip address show dev wlan0
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc prio state DOWN group default qlen 1000
    link/ether b8:27:eb:14:63:ea brd ff:ff:ff:ff:ff:ff
    inet 10.63.5.1/8 brd 10.255.255.255 scope global wlan0
       valid_lft forever preferred_lft forever
20.06.2017859PackagesBug ReportVery LowMediumOpenVPN is beeing killed with "service openvpn stop" du...lede-17.01Assigned Task Description

TP-LINK TL-MR-3220 v.2.x with LEDE 17.01.2 onboard, installed OpenVPN.

Connection opens successfully, however, on stopping with “service openvpn stop”, logread shows:

Tue Jun 20 08:36:35 2017 daemon.info procd: Instance openvpn::instance1 pid 4084 not stopped on SIGTERM, sending SIGKILL instead
Tue Jun 20 08:36:35 2017 daemon.notice netifd: Network device ‘tun0’ link is down
Tue Jun 20 08:36:35 2017 daemon.notice netifd: Interface ‘vyprvpn’ has link connectivity loss

This causes OpenVPN scripts to abort.

If stopping openvpn with “killall -TERM openvpn”, then it gets enough time to end in a nice way and all scripts are OK.

22.06.2017863KernelBug ReportMediumMediumath9k failure with AP+11s VIFs ("unsupported hw bitrate...lede-17.01Assigned Task Description

A Gluon user reported the following issue, observed on a TL-WR841N v9 (QCA953x). LEDE version is 17.01.2.

Gluon uses AP+11s VIFs, with multicast_rate set to 12000.

The WLAN became unusable (no connection possible, WLAN LED permantently on) after a few hours of operation. Both VIFs were affected. The system recovered on its own after an hour in this state. Unfortunately, I have no information if beacons were still running in the broken state.

After the recovery, the large number of messages like the following were found in the kernel log:

[40085.953696] ath: phy0: unsupported hw bitrate detected 0x73 using 1 Mbit
[40200.844082] ath: phy0: unsupported hw bitrate detected 0x48 using 1 Mbit
[40281.298039] ------------[ cut here ]------------
[40281.303081] WARNING: CPU: 0 PID: 0 at compat-wireless-2017-01-31/net/mac80211/rx.c:4214 ieee80211_rx_napi+0x130/0x8b0 [mac80211]()
[40281.315230] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 100 (0x64)
[40281.325023] Modules linked in: iptable_nat ath9k nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE ebtable_nat ebtable_filter ebtable_broute ath9k_common xt_time xt_tcpudp xt_state xt_quota xt_pkttype xt_physdev xt_owner xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_addrtype xt_TCPMSS xt_REDIRECT xt_LOG xt_CT nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack mac80211 iptable_mangle iptable_filter ip_tables ebtables ebt_vlan ebt_stp ebt_snat ebt_redirect ebt_pkttype ebt_mark_m ebt_mark ebt_limit ebt_ip6 ebt_ip ebt_dnat ebt_arpreply ebt_arp ebt_among ebt_802_3 br_netfilter ath9k_hw ath em_nbyte em_cmp sch_pie em_meta sch_gred sch_teql act_ipt sch_prio em_text sch_codel sch_red sch_fq sch_sfq sch_dsmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_htb sch_hfsc batman_adv libcrc32c cfg80211 compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables dummy veth tun act_police cls_basic sch_tbf sch_ingress gpio_button_hotplug crc16 crc32c_generic crypto_hash
[40281.433128] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.4.71 #0
[40281.440330] Stack : 803e32a4 00000000 00000001 80440000 8042d1dc 8042ce63 803c48ac 00000000
[40281.440330]    804a378c 00000004 00000000 8180e918 00000000 800a7664 803c9fa8 80430000
[40281.440330]    00000003 00000004 803c83b4 81809d5c 00000000 800a55e0 00000002 00000000
[40281.440330]    8042bf70 801f5300 00000000 00000000 00000000 00000000 00000000 00000000
[40281.440330]    00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[40281.440330]    ...
[40281.477351] Call Trace:
[40281.479951] [<800a7664>] vprintk_default+0x24/0x30
[40281.484917] [<800a55e0>] printk+0x2c/0x38
[40281.489077] [<801f5300>] serial8250_get_mctrl+0x30/0x54
[40281.494512] [<80081c60>] warn_slowpath_common+0xa0/0xd0
[40281.499949] [<801a772c>] dump_stack+0x14/0x28
[40281.504473] [<80071ea8>] show_stack+0x50/0x84
[40281.509003] [<80081c60>] warn_slowpath_common+0xa0/0xd0
[40281.514543] [<80e25cf0>] ieee80211_rx_napi+0x130/0x8b0 [mac80211]
[40281.520918] [<80081cbc>] warn_slowpath_fmt+0x2c/0x38
[40281.526158] [<80e25cf0>] ieee80211_rx_napi+0x130/0x8b0 [mac80211]
[40281.532495] [<802623ec>] __build_skb+0x48/0xc8
[40281.537148] [<802625d0>] __netdev_alloc_skb+0xd0/0x148
[40281.542477] [<80060bf4>] handle_int+0x134/0x140
[40281.547181] [<80de8388>] ath9k_cmn_rx_skb_postprocess+0x50/0x168 [ath9k_common]
[40281.554852] [<80e88374>] ath_rx_tasklet+0xee8/0xf4c [ath9k]
[40281.560635] [<8006503c>] __bzero+0xa0/0x164
[40281.565012] [<80e88340>] ath_rx_tasklet+0xeb4/0xf4c [ath9k]
[40281.570828] [<80e851b8>] ath9k_tasklet+0x200/0x28c [ath9k]
[40281.576512] [<80084820>] tasklet_action+0x80/0xc8
[40281.581390] [<800841dc>] __do_softirq+0x250/0x298
[40281.586284] [<800a82bc>] generic_handle_irq+0x24/0x3c
[40281.591540] [<8006a9e0>] plat_irq_dispatch+0xd4/0x10c
[40281.596760] [<80060bf4>] handle_int+0x134/0x140
[40281.601447]
[40281.602992] ---[ end trace f41ea26ed5101c02 ]---

Both the numbers in the “unsupported hw bitrate detected” messages and the status→rate_idx values in the WARNINGs are seemingly random.

04.09.2016153KernelBug ReportVery LowLowKERNEL_DYNAMIC_FTRACE=y on mips => panic TrunkAssigned Task Description

Github issue #129 reported by: https://github.com/stsydow

If KERNEL_DYNAMIC_FTRACE is enabled on a MIPS system it will panic in late boot. (tested on ar71xx and malta)
The error message is not very helpful, maybe some one has an idea how to track it down:

[    5.579744] procd: - init -
Please press Enter to activate this console.
[    5.854903] CPU 0 Unable to handle kernel paging request at virtual address 00c03849, epc == 8026a400, ra == 8026a3e4
[    5.855392] Oops[#1]:
[    5.855602] CPU: 0 PID: 1611 Comm: kmodloader Not tainted 4.4.13 #20
[    5.855862] task: 8d86a0a0 ti: 8fa22000 task.ti: 8fa22000
[    5.856060] $ 0   : 00000000 8026a3e4 80130620 00000000
[    5.856380] $ 4   : 8dc48ab0 00000001 0000000e 81b97540
[    5.856607] $ 8   : 0024f000 00003edc 00000000 00000001
[    5.856795] $12   : 8d8410c0 00000025 00000000 6261745f
[    5.856984] $16   : 8dc48a80 81980000 00c03821 801305f4
[    5.857174] $20   : 8dc48ad9 80130620 0000001d 024000c0
[    5.857362] $24   : 00000000 8015655c                  
[    5.857569] $28   : 8fa22000 8fa23bd0 80194d48 8026a3e4
[    5.857766] Hi    : 00000018
[    5.857863] Lo    : 00000007
[    5.858008] epc   : 8026a400 proc_register+0x74/0x130
[    5.858167] ra    : 8026a3e4 proc_register+0x58/0x130
[    5.858317] Status: 1000b703 KERNEL EXL IE 
[    5.858529] Cause : 00800008 (ExcCode 02)
[    5.858655] BadVA : 00c03849
[    5.858764] PrId  : 00019300 (MIPS 24Kc)
[    5.858895] Modules linked in: ip6_tables(+) x_tables mii
[    5.859219] Process kmodloader (pid: 1611, threadinfo=8fa22000, task=8d86a0a0, tls=77528e48)
[    5.859477] Stack : 8da50000 8026a1a4 8f898000 81b94a40 81945a40 8014d8c4 00000001 8dc48a80
      8da4e540 00000000 8f9d6370 8da50000 8da50000 8026a724 00000000 80650000
      8da4e400 00000000 8f9d6370 80650000 8da4e400 8da4d134 00000000 8d86a0e8
      801305f4 00000000 00000000 5ce6d83d 81b94a40 61745f78 73656c62 6d616e5f
      8d007365 0000af3b 81b94a40 81b94a40 8dad46b0 00000000 8fa23d30 80650000
      ...
[    5.861631] Call Trace:
[    5.861728] [<8026a400>] proc_register+0x74/0x130
[    5.861954] [<8026a724>] proc_create_data+0xac/0xd8
[    5.862188] [<8da4d134>] xt_proto_init+0xa4/0x1d0 [x_tables]
[    5.862414] [<8042e640>] ops_init.constprop.9+0x10c/0x150
[    5.862593] [<8042e71c>] register_pernet_operations.isra.4+0x98/0xec
[    5.862796] [<8042e7a4>] register_pernet_subsys+0x34/0x58
[    5.862986] [<8f9d7030>] init_module+0x28/0xcc [ip6_tables]
[    5.863174] [<801006b4>] do_one_initcall+0x1f8/0x224
[    5.863341] [<801c5c8c>] do_init_module+0x84/0x1f8
[    5.863504] [<80197ca0>] load_module+0x1888/0x1d58
[    5.863680] [<80198290>] SyS_init_module+0x120/0x164
[    5.863846] [<80113908>] syscall_common+0x30/0x54
[    5.864046] 
[    5.864130] 
Code: 12400014  26040030  92060058 <92420028> 00c2182b  14600008  00000000  0046102b  14400009 
[    5.864794] ---[ end trace 6cd948b6ebb870af ]---

To test, try this config: config.zip

(default config for malta-mips + KERNEL_DYNAMIC_FTRACE)
and run

qemu-system-mipsel -kernel bin/targets/malta/le/lede-malta-le-vmlinux-initramfs.elf -nographic -m 256

Full boot log: crash-dyn-trace.log.txt

13.10.2016224Base systemBug ReportVery LowLowwrong source IP when logging to remote IPv6 syslog serv...TrunkAssigned Task Description

Hello,

I’m trying to send log to remote IPv6 syslog server (x:y:z:12::1), but packets received by syslog server are invalid. Instead of public IPv6 address, syslog udp packets are sent with ::1 source IP and therefore ignored by destination server. Logging over IPv4 works ok.

tcpdump log from destination syslog server:
23:34:16.988433 IP6 ::1.38044 > x:y:z:12::1.514: SYSLOG daemon.notice, length: 65

Configuration:

/etc/config/system:

 option log_ip 'x:y:z:12::1'

Device is in the same range as syslog server (x:y:z:12::119/64) and has native IPv6 connectivity. Other services (dropbear, ntp client, snmpd, luci) are running fine over IPv6.

Device is TP-Link WDR3600, running lede reboot-1818-gb81fc29.

10.04.2017699Base systemBug ReportVery LowLowpackages install conflictTrunkAssigned Task Description

Supply the following if possible:
- Xiaomi Mini
- snapshot from 9.4.2017./happened few weeks ago too
- try to build image will fail in the end of the process

 

because of procps-ng free, pgrep, top, uptime which conflict with busybox version of the same apps

03.05.2017758Base systemBug ReportMediumLowfactory image for ubnt er-x missinglede-17.01Assigned Task Description

lede-ramips-mt7621-ubnt-erx-initramfs-factory.tar isn’t part of the released files though it is needed to initially flash the device when still operating the factory firmware.

27.05.2017814Base systemBug ReportVery LowLowWhen LEDE is compiled with GCC 7 on at least ar71xx and...TrunkAssigned Task Description

When using the GCC 7.x compiler, I have found that Dropbear in LEDE images for ar71xx (Ubiquiti Unifi) and brcm47xx (generic) (built with the default configuration, other than changing the compiler to GCC 7.x) won’t accept incoming SSH connections. Instead, as soon as a connection is received, it spins the CPU indefinitely and the connecting SSH client hangs. Nothing relevant is printed in the logs. This behavior does not occur on x86_64; there Dropbear works fine.

I realize I haven’t provided much information here, but I don’t really know how to collect anything else on embedded platforms like this. One of the devices on which I have reproduced this does have a serial adapter though, so I can use that to get any additional information that might be helpful.

10.06.2017837Base systemFeature RequestMediumLowPROVIDES handling for non-virtual packagesTrunkAssigned Task Description

The build system should allow adding PROVIDES for existing package names, to facilitate replacing core packages. At the moment, adding such PROVIDES will not lead to the desired dependencies.

Example: ip-tiny and ip-full both provide ip, the generated Kconfig for +ip depends looks like this:

select PACKAGE_ip-tiny if !PACKAGE_ip-full

This would not work if ip-full was just called ip (applying the following patch to show the issue):

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 364c1b22a1..d7933ede54 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -39,11 +39,10 @@ $(call Package/iproute2/Default)
  ALTERNATIVES:=200:/sbin/ip:/sbin/ip-tiny
 endef
 
-define Package/ip-full
+define Package/ip
 $(call Package/iproute2/Default)
  TITLE:=Routing control utility (Full)
  VARIANT:=full
- PROVIDES:=ip
  ALTERNATIVES:=300:/sbin/ip:/sbin/ip-full
 endef
 
@@ -120,7 +119,7 @@ define Package/ip-tiny/install
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/sbin/ip-tiny
 endef
 
-define Package/ip-full/install
+define Package/ip/install
 	$(INSTALL_DIR) $(1)/sbin
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/sbin/ip-full
 endef
@@ -158,7 +157,7 @@ define Package/devlink/install
 endef
 
 $(eval $(call BuildPackage,ip-tiny))
-$(eval $(call BuildPackage,ip-full))
+$(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
 $(eval $(call BuildPackage,ip-bridge))

The Kconfig looks like this now:

select PACKAGE_ip

instead of the expected

select PACKAGE_ip if !PACKAGE_ip-tiny

I expect this can be solved by separating the “vdepends” list from the package list, making each package provide itself, and always resolving DEPENDS through vdepends.

18.06.2017853Base systemBug ReportVery LowLowChange dnsmasq domain and local options to listsTrunkAssigned Task Description

On LEDE 17.01 ‘domain’ and ‘local’ options in dnsmasq configuration doesn’t correctly support lists values as per dnsmasq capabilities.

Steps to reproduce

#/etc/config/dhcp
[...]
config dnsmasq
        list domain 'example1.com,192.168.0.0/24'
        list domain 'example2.com,192.168.1.0/24'
        list local '/example1.com/'
        list local '/example2.com/'
[...]

$ uci commit dhcp
$ /etc/init.d/dnsmasq restart

Actual results

#/var/etc/dnsmasq.conf.cfg02411c
[...]
domain=example1.com,192.168.0.0/24 example2.com,192.168.1.0/24
local=/example1.com/ /example2.com/
[...]

Expected results

#/var/etc/dnsmasq.conf.cfg02411c
[...]
domain=example1.com,192.168.0.0/24
domain=example2.com,192.168.1.0/24
local=/example1.com/
local=/example2.com/
[...]

Workaround

Replace append_parm with config_list_foreach here resolve the issue.
I’m attaching a patch for the 17.01 dnsmasq init script but it will break old uci configuration that use ‘option’ instead of ‘list’.
Do you have any suggestion on how to migrate old configuration and set those parameters as lists in uci web interface?

05.11.20171150KernelBug ReportVery LowVery Lowkernel module zram depends on CONFIG_CRYPTO_LZO and CON...TrunkAssigned Task Description

On target ar71xx zram-swap doesn’t work anymore since changing kernel version 4.4 to 4.9.

It seems the zram module now depends on the CONFIG_CRYPTO_LZO and CONFIG_CRYPTO_LZ4 modules

Supply the following if possible:
- Device problem occurs on

DIR-505 and Archer C7

- Software versions of LEDE release, packages, etc.

Trunk

- Steps to reproduce

 

Select zram-swap and either revert back to kernel 4.4 by changing target/linux/ar71xx/Makefile

Or manually run kernel_menuconfig with ‘make kernel_menuconfig CONFIG_TARGET=generic’ and enable CONFIG_CRYPTO_LZ4=y and CONFIG_CRYPTO_LZO=y


10.02.2017494Base systemBug ReportVery LowCriticalNETDEV WATCHDOG: ptm0 (): transmit queue 0 timed outAllNew Task Description

I have a VDSL line with Plusnet (UK) - the connection is pppoe - ptm0.101. With the supplied modem/router the line and connection is stable with no disconnects. With LEDE the connection is established and works well until it disconnects (sometimes as early as few minutes other times it stays connected up to an hour). After the disconnect there is no reconnection until a reboot. Restarting wan interface (ifdown wan/ifup wan) or dsl connection (/etc/init.d/dslcontrol stop/start) does not help.

Supply the following if possible:
- Device problem occurs on TP-w8970 and BTHomehub 5A (same crash on both lantiq based devices)
- Software versions of LEDE release, packages, etc. Tested on LEDE RC2, earlier LEDE snapshot from October 2016, Openwrt CC - same symptoms
- Steps to reproduce - VDSL connection on ptm0.101 via pppoe

Here is a trace of the crash (dmesg):

[ 1414.124413] —[ beginning trace ff034b465cdad16b ]— [ 1414.125631] WARNING: CPU: 0 PID: 0 at net/sched/sch_generic.c:303 dev_watchdog+0x1a8/0x2f0()
[ 1414.126471] NETDEV WATCHDOG: ptm0 (): transmit queue 0 timed out
[ 1414.132456] Modules linked in: ltq_ptm_vr9 option iptable_nat ath9k usb_wwan rt2800usb rt2800lib
pppoe nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 l2tp_ppp ipt_REJECT ipt_MASQUERADE ath9k_common
xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_policy xt_nat xt_multiport xt_mark xt_mac
xt_limit xt_length xt_id xt_hl xt_helper xt_esp xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit
xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY usbserial rt2x00usb
rt2x00lib pppox ppp_async nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6
nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack ltq_deu_vr9 iptable_raw iptable_mangle iptable_filter ipt_ah ipt_ECN
ip_tables crc_itu_t crc_ccitt cdc_acm ath9k_hw ath10k_pci ath10k_core ath mac80211 cfg80211 compat drv_dsl_cpe_api
drv_mei_cpe xt_set ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net
ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark
ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6t_REJECT nf_reject_ipv6
nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables pppoatm ppp_generic slhc
l2tp_ip6 l2tp_ip l2tp_eth sit l2tp_netlink l2tp_core udp_tunnel ip6_udp_tunnel ipcomp xfrm4_tunnel xfrm4_mode_tunnel
xfrm4_mode_transport xfrm4_mode_beet esp4 ah4 tunnel4 ip_tunnel tun af_key xfrm_user xfrm_ipcomp xfrm_algo br2684 atm
drv_ifxos echainiv sha256_generic sha1_generic jitterentropy_rng drbg md5 hmac des_generic cbc authenc usb_storage
dwc2 uhci_hcd ehci_platform ehci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache aead crypto_null
[ 1414.287462] CPU: 0 PID: 0 Comm: swapper Not tainted 4.4.7 #1
[ 1414.293130] Stack : 804b0000 00000001 00000000 00000000 805172b8 80516f43 80489a24 00000000
[ 1414.293130] 80673844 00010000 80510000 805159bc 80515abc 80055664 00000003 80510000
[ 1414.293130] 80491b4c 00000000 8048ff50 80511c44 80515abc 800535b0 00000006 00000001
[ 1414.293130] 00000000 80512000 00000000 00000000 00000000 00000000 00000000 00000000
[ 1414.293130] 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[ 1414.293130] ...
[ 1414.328618] Call Trace:
[ 1414.331095] [<800178a8>] show_stack+0×50/0×84 [ 1414.335454] [<8002af48>] warn_slowpath_common+0xa0/0xd0
[ 1414.340670] [<8002afa4>] warn_slowpath_fmt+0x2c/0×38 [ 1414.345636] [<802e637c>] dev_watchdog+0x1a8/0x2f0
[ 1414.350348] [<8005f7b0>] call_timer_fn.isra.5+0×24/0×80 [ 1414.355557] [<8005fa2c>] run_timer_softirq+0x1a4/0×208 [ 1414.360694] [<8002de80>] __do_softirq+0×298/0x2b0
[ 1414.365388] [<80002430>] ret_from_irq+0×0/0×4 [ 1414.369760] [<80013a8c>] r4k_wait_irqoff+0×18/0×20 [ 1414.374528] [<8004ff6c>] cpu_startup_entry+0xa4/0xf8
[ 1414.379508] [<80539bf8>] start_kernel+0×474/0×494 [ 1414.384180]
[ 1414.385631] —[ end trace ff034b465cdad16b ]—

 


Showing tasks 1 - 50 of 375 Page 1 of 81 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing